Bug 15899 - LILO unable to install on RAID partitions, must use MBR...
LILO unable to install on RAID partitions, must use MBR...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 20:39 EDT by John Cagle
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 09:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2000-08-09 20:39:37 EDT
Boot failed on ProLiant ML330 using LC2 controller as a boot device during installation.  It appears that LILO is unable to properly handle 
installing to partitions on RAID (or Array) controllers, and must install to the MBR instead.

H/W
System: ML330
controller: boot - <A HREF="http://www.compaq.com/products/quickspecs/10652_na/10652_na.HTML">RAID LC2 Controller</A>
	other - Embedded SCSI

S/W
OS: Redhat 7.0 beta 5
Partition: / - /dev/ida/c0d0p1
               swap - /dev/ida/c0d0p5
lilo config: /dev/ida/c0d0p1

Steps:
1. Erase the system using Smartstart
2. Start Installation
3. Add partition:  / - /dev/ida/c0d0p1   swap - /dev/ida/c0d0p5
4. Configure lilo on /dev/ida/c0d0p1
5. make boot disk
6. reboot 
7. boot stops at "attempting boot from hard drive (c:)"

Workaround:
boot from floppy made during installation and edit "boot=/dev/ida/c0d0p1" to "boot=/dev/ida/c0d0" in lilo.conf and re-run "lilo"
Comment 1 Glen Foster 2000-08-13 14:09:53 EDT
I don't know if we have this hardware in-house.  Are you willing (assuming we
don't have it) to send a unit here to Durham so we have time to reproduce this
behavior, if it comes to it?  We're really running short on time for Winston. 
I'll get back with you SOON on this either way.
Comment 2 John Cagle 2000-08-13 14:17:45 EDT
Yes.  Do you just need the LC2 controller?  Just let me know your shipping address.
Comment 3 Glen Foster 2000-08-13 16:52:14 EDT
... ship to:

Glen Foster
Red Hat, Inc.
2600 Meridian Parkway
Durham, NC 27713
Comment 4 Glen Foster 2000-08-13 16:52:33 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 5 Preston Brown 2000-08-15 11:43:24 EDT
LILO only supports booting raid partitions off of the MBR.  There is no need to
put it on the first sector of the partition -- the only time you would ever need
to do that is in a dual-boot situation.
Comment 6 John Cagle 2000-08-17 11:57:45 EDT
We install Red Hat on bootable hardware arrays all the time, and we don't put LILO on the MBR.
We have to maintain the legacy MBR to allow the F10 key to boot the Compaq System Partition.
We always put LILO on /boot.

BTW, Glen received the LC2 controller this morning.
Comment 7 Doug Ledford 2000-08-22 09:46:37 EDT
Lilo usually works fine from a partition table entry.  *However*, lilo makes no
attempt to ensure that a DOS compatible master boot record is in place when lilo
is installed to the partition instead of the master boot record.  The
description you give above sounds like the master boot record of the system
might be wiped out.  If, instead of using the workaround you have listed, you
instead put a DOS floppy into the drive and run fdisk /mbr to make sure that
there is a valid master boot record does that help?  What about the partitions
themselves?  Did you use Disk Druid or fdisk, and since you are wanting lilo on
the partition, did you make sure that the partition you put lilo on to is marked
as active in the partition table?
Comment 8 John Cagle 2000-08-22 16:56:16 EDT
After retesting, we agree -- must have been a bad MBR.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.