Bug 1590 - /usr/share/vim/macros/vimrc contains "set backupdir=/tmp/vim_backup"
/usr/share/vim/macros/vimrc contains "set backupdir=/tmp/vim_backup"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-17 17:44 EST by Steve Wills
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-23 10:59:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wills 1999-03-17 17:44:30 EST
Summary says it all. Having this line in this vimrc causes
errors when using /usr/bin/cvim if /tmp/vim_backup doesn't
exist. Remove this line.
Comment 1 Preston Brown 1999-03-18 15:49:59 EST
Doesn't cvim simply create the directory if it doesn't exist?
Comment 2 Steve Wills 1999-03-18 15:59:59 EST
No. It says:

"filename" Cannot create backup file (use ! to override)
Comment 3 Erik Troan 1999-03-23 10:59:59 EST
fixed in vim 5.3-6 -- I couldn't reproduce the error message, but
having that in the default vimrc is undoutedly wrong

Note You need to log in before you can comment on or make changes to this bug.