Bug 159008 - preun script failure while removing sets of packages leads to unmet dependencies
preun script failure while removing sets of packages leads to unmet dependencies
Status: CLOSED DUPLICATE of bug 89500
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-05-27 12:32 EDT by Nat Budin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-20 16:13:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nat Budin 2005-05-27 12:32:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 SUSE/1.0.4-1.1

Description of problem:
If package A requires package B, and both are installed, and you attempt to remove both at once using rpm --erase, and A's preun script fails, B will still be removed, which leaves A installed and B not installed.  Since A requires B, this situation should not occur.

As an example, on RHEL 4AS, there are several packages that depend on metacity, one of which is firstboot.  If you use rpm --erase to remove these packages all at once, metacity's removal will succeed, but firstboot's preun scriptlet fails.  At the end of the transaction, metacity has been removed, but firstboot remains.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. On a stock RHEL 4AS install, run the following command as root: rpm --erase gnome-volume-manager gnome-session control-center system-config-display firstboot metacity
2. Run the following command: rpm -q firstboot metacity


Actual Results:  During step 1, firstboot's preun script failed.  Step 2 returned the following output:

package metacity is not installed

Expected Results:  RPM should have attempted to uninstall firstboot BEFORE uninstalling metacity.  Since firstboot could not successfully be removed, RPM should have refused to remove metacity.

Additional info:
Comment 1 Paul Nasrat 2005-05-27 13:14:59 EDT
RPM in RHEL has never done sorted erasures based on requirements.

Work is going on in Fedora and rpm-4.4.x/HEAD atm to get sorted erasures working.
Comment 2 Jeff Johnson 2006-01-20 16:13:50 EST

*** This bug has been marked as a duplicate of 89500 ***

Note You need to log in before you can comment on or make changes to this bug.