Bug 1590202 - [RFE] Disable Event notification popup in admin portal
Summary: [RFE] Disable Event notification popup in admin portal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Greg Sheremeta
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks: 1608362
TreeView+ depends on / blocked
 
Reported: 2018-06-12 08:15 UTC by vaibhav
Modified: 2021-09-09 14:35 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Enhancement
Doc Text:
This release adds a feature to control toast notifications. Once any notifications are showing, "Dismiss" and "Do not disturb" buttons will appear that allow the user to silence notifications.
Clone Of:
: 1608362 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:37:41 UTC
oVirt Team: UX
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)
Hidden content on a form (77.18 KB, image/png)
2018-06-12 11:09 UTC, Roman Hodain
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-43521 0 None None None 2021-09-09 14:35:08 UTC
Red Hat Knowledge Base (Solution) 3490061 0 None None None 2018-06-19 10:45:43 UTC
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:38:00 UTC
oVirt gerrit 92443 0 'None' 'MERGED' 'webadmin: notifications drawer' 2019-12-04 12:34:28 UTC
oVirt gerrit 92896 0 'None' 'MERGED' 'webadmin: notifications drawer' 2019-12-04 12:34:28 UTC

Description vaibhav 2018-06-12 08:15:35 UTC
Description of problem:

There are multiple popup coming for the event notification in RHV portal. Wen there is any event happene at that time popup will come in admin portal. 
Currently there is no way to disable this popups, we want feature to disable this event notification popup in RHVM portal. 

Version-Release number of selected component (if applicable):

Red Hat Virtualization 4.2

How reproducible:

100%

Steps to Reproduce:
1. If there is an event then popup will come into RHV admin portal.


Actual results:

Popup coming for the events as notification box in RHV portal.

Expected results:-

There should be some way to disable this event notification popup.


Additional info:-

NA.

Comment 1 Roman Hodain 2018-06-12 11:09:39 UTC
Created attachment 1450445 [details]
Hidden content on a form

Here is an example of the issue. In some cases when the environment is busy there is almost no chance to remove these popups and it prevents the user from using the portal.

Comment 2 Greg Sheremeta 2018-06-14 17:43:00 UTC
Definitely an issue, and I can think of a few ways to solve from a UX perspective.

Liz, can you provide your opinion?

Comment 3 Tomas Jelinek 2018-06-15 07:01:29 UTC
I agree with Greg, not necessarily disable completely, but do some UX magic to make it more consumable and less disturbing.

Comment 5 Liz 2018-06-18 17:51:19 UTC
Hi all,

I think allowing the user to disable notifications as a feature, close all, or snooze are features that are avoiding the current problem. It would be great if we could pick up on the situations where we could let the user know in "bulk" that a number of things have happened. In this specific case, it would be really nice for the notification to be "6 VMs have been removed...". The user wouldn't feel like they've gotten a storm of notifications and it would scale to 100s of notifications if needed. Would it be technically possible to lump these together into one notification?

In some cases, the application might be experiencing the same issue over and over in which case it would be great to identify if that's happening and just notify the user once rather than with multiple. (This could be a case for allowing an action of "Don't notify me again about this"). Here's an example of ManageIQ handling this situation:
https://github.com/ManageIQ/manageiq-ui-service/pull/751

I think if we come across a use case where it does make sense to list out each toast notification individually, we should consider a "Clear All" feature, but it would be good to understand if there truly is a use case for this, or if we just need to be careful and considerate about which actions might cause a number of notifications at once.

What do folks think?

Thanks,
Liz

Comment 6 Yaniv Kaul 2018-06-18 21:16:29 UTC
(In reply to Liz from comment #5)
> Hi all,
> 
> I think allowing the user to disable notifications as a feature, close all,
> or snooze are features that are avoiding the current problem. It would be
> great if we could pick up on the situations where we could let the user know
> in "bulk" that a number of things have happened. In this specific case, it
> would be really nice for the notification to be "6 VMs have been
> removed...". The user wouldn't feel like they've gotten a storm of
> notifications and it would scale to 100s of notifications if needed. Would
> it be technically possible to lump these together into one notification?
> 
> In some cases, the application might be experiencing the same issue over and
> over in which case it would be great to identify if that's happening and
> just notify the user once rather than with multiple. (This could be a case
> for allowing an action of "Don't notify me again about this"). Here's an
> example of ManageIQ handling this situation:
> https://github.com/ManageIQ/manageiq-ui-service/pull/751
> 
> I think if we come across a use case where it does make sense to list out
> each toast notification individually, we should consider a "Clear All"
> feature, but it would be good to understand if there truly is a use case for
> this, or if we just need to be careful and considerate about which actions
> might cause a number of notifications at once.
> 
> What do folks think?
> 
> Thanks,
> Liz

1. We might need some event supression mechanism. It sometimes may not make sense to output the same / similar event to the user multiple times in succession.
2. Do events by other users pop up?
3. I wonder if we should not pop up events for items originated from the API (not sure how feasible this is!)
4. Perhaps just alerts/warnings/async tasks?

Comment 8 Greg Sheremeta 2018-07-16 13:18:15 UTC
@QE, to test, you'll need to do a mass operation that will cause 3 or more toast notifications to occur within 8 seconds.

Comment 9 RHV bug bot 2018-07-24 12:26:36 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 13 Pavel Novotny 2019-01-29 16:45:13 UTC
Verified in
rhvm-4.3.0-0.8.rc2.el7.noarch
ovirt-engine-webadmin-portal-4.3.0-0.8.rc2.el7.noarch

New button Dismiss All and all the Do Not Disturb buttons work as expected.

Comment 15 errata-xmlrpc 2019-05-08 12:37:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.