Bug 15903 - gcc crash on compile of 2.4t5.
gcc crash on compile of 2.4t5.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 23:56 EDT by John Bloodworth
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 22:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Bloodworth 2000-08-09 23:56:36 EDT
this is on a stock pinstype install.  I was board this weekend and picked 
up an amd k6-2 500 and fic mbd.  system has 128 meg of ram.
install went fine however, I wanted to play with 2.4t5 and see how well it 
worked on this system.  I downloaded the latest 2.4t5 tar.gz from 
kernel.org and unzipped and un tared to a directory under /root. frome 
here I did an mv /linux /usr/src/linux-2.4.0-test5 removed teh current sym 
link to linux and re set as ln -s /usr/src/linux-2.4.0-test5 /usr/src/linux
cd to linux
ran make clean
ran make menuconfig 
     added amd k-6 proc famley
     added usb
     removed scsi ( none on my box)
     added vt82688 sound support
saved config
ran make dep ( fine)
ran make bzImage (crash)
tried just a make (crash)
tried make kernel (crash)
same config will compile on a compaq (RH 6.2) at work and my toshiba 
infina ( currently suse 6.2) at home
crash is alwase at the same point.    
here is a copy of compile   
gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2 -
fomit-f
rame-pointer -pipe  -mpreferred-stack-boundary=2 -march=k6 -fno-strict-
aliasing
 -DUTS_MACHINE='"i386"' -c -o init/version.o init/version.c
make CFLAGS="-D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-
prototypes -O2
 -fomit-frame-pointer -pipe  -mpreferred-stack-boundary=2 -march=k6 -fno-
strict-
aliasing " -C  kernel
make[1]: Entering directory `/usr/src/linux/kernel'
make all_targets
make[2]: Entering directory `/usr/src/linux/kernel'
gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -O2 -
fomit-f
rame-pointer -pipe  -mpreferred-stack-boundary=2 -march=k6 -fno-strict-
aliasing
   -DEXPORT_SYMTAB -c signal.c
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[2]: *** [signal.o] Error 1
make[2]: Leaving directory `/usr/src/linux/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [_dir_kernel] Error 2
dont know where the dependicy tree is failing on pinstrype but I can 
compile with 6.2 ( redhat)
Comment 1 John Bloodworth 2000-08-10 00:08:47 EDT
I forgot to say that if I change the makefile to use regular pent.. 
optimazations the compile will run fine.
Comment 2 Preston Brown 2000-08-15 11:43:56 EDT
use kgcc instead.
Comment 3 John Bloodworth 2000-08-15 22:28:16 EDT
cool that worked.... it evenn works with test6.
Comment 4 Jakub Jelinek 2000-08-25 11:41:17 EDT
I have just built our 2.4.0-test6-pre7 based kernel with CONFIG_MK6=y without
a single problem. Please reopen the bug with a gcc -v -save-temps output
of compilation of some file which is crashing (and send me both the output
and .i file generated by that command) if you still see problems with the latest
gcc package in rawhide.

Note You need to log in before you can comment on or make changes to this bug.