Bug 159039 - kde application crash while closing after upgrade from update 4 to update 5
kde application crash while closing after upgrade from update 4 to update 5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdelibs (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Petr Rockai
:
: 159040 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-27 19:16 EDT by Wesly Chen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 06:54:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesly Chen 2005-05-27 19:16:59 EDT
Description of problem:
The RedHat Desktop 3.0 upgraded from update 4 to update 5, after reboot, all
the KDE applications, i.e. kdesktop_lock, carsh after exit/closing.
The detail message complain about db library /lib/tls/libthread_db.so.1.



Version-Release number of selected component (if applicable):
kdelibs-3.1.3-6.10

How reproducible:


Steps to Reproduce:
1. Login to KDE session
2. Open Kterminal or the screen_lock kick off automatically after a period of 
idle time
3. Close the Kterminal or unlock the screen. Bang!!
  
Actual results:
unknown - The KDE Crash Handler
The application unknown (kdesktop_lock) crashed and caused the signal 11 
(SIGSEGV).

Expected results:
No crash.

Additional info:
Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1073842432 (LWP 26164)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x002d988e in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#0  0x002d988e in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#1  0x001ed00d in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x0062cbea in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#4  0x08ea00f0 in ?? ()
#5  0x0065e540 in ?? () from /usr/lib/libGL.so.1
#6  0x08ea00f0 in ?? ()
#7  0x0062eed6 in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#8  0x08ea00f0 in ?? ()
#9  0x08ea00f0 in ?? ()
#10 0x00936c84 in ?? () from /usr/X11R6/lib/libX11.so.6
#11 0x08ea5990 in ?? ()
#12 0x0086d422 in XCloseDisplay () from /usr/X11R6/lib/libX11.so.6
#13 0x010d250b in qt_cleanup () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#14 0x0112d5b4 in QApplication::~QApplication$base ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x001840ca in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#16 0x08053847 in ?? ()
#17 0xbfff9b90 in ?? ()
#18 0x080546fd in _IO_stdin_used ()
#19 0x00000001 in ?? ()
#20 0x00000000 in ?? ()
Comment 1 Suzanne Hillman 2005-05-31 14:50:22 EDT
*** Bug 159040 has been marked as a duplicate of this bug. ***
Comment 2 Suzanne Hillman 2005-05-31 14:58:10 EDT
Did this happen on more than one machine? What were the specs of the hardware in
the machine(s) this happened on?
Comment 3 Wesly Chen 2005-05-31 17:16:17 EDT
It happens on at least two machines. 
One is Dell Precision WorkStation 530 with Nvidia Quadro2 Pro video card 
and the other is HP XW4200 with Nvidia Quadro FX1300 video card.

I checked the machine with REHL 3.0 update 4, I found the only difference 
between update 4 and update 5 is kdebase, which is 3.1.3-5.8 and 3.1.3-5.9 
separately
Comment 5 Håkon Enger 2005-06-23 11:50:54 EDT
I had this problem (crash on exit from all KDE applications in
glXChannelRectSyncSGIX within KApplication::~KApplication) on a Dell Optiplex
GX260 with nvidia drivers installed. In my case it seems that the problem was
that I had forgotten to update the XF86Config file to use the nvidia driver.
Probably nVidia's libGL.so prefers that the nvidia driver is being used.
Comment 6 Petr Rockai 2005-10-03 15:21:28 EDT
Can anyone else please check if the problem is related to nvidia drivers? All     
the affected hardware seems to run on nvidia hardware, could you provide    
details on the drivers installed? Also, did anything x11-related change in the    
update? Does switching the driver (to the other than you are using when the   
crash is present, "nv" as shipped with RHEL or binary "nvidia" driver). In any  
case, does disabling glx help? 
 
Note that from kdebase changelog the version that seems to introduce the crash 
apparently didn't contain any change that could cause the change in behaviour. 
The only change is in xinerama code of kicker (the kde panel). 
Comment 7 Petr Rockai 2006-01-19 07:35:24 EST
Waiting for reporter to provide more details. This is most probably not a kde 
bug, but want to be sure.  
Comment 8 Wesly Chen 2006-01-19 16:30:30 EST
It seems to related to the nvidia driver issue.
It requires to re-compile the nvidia driver every time you upgrade the kernel.
After re-compiling the nvidia driver, the problem went away.
Thanks Peter.
Comment 9 Petr Rockai 2006-03-22 06:54:36 EST
Closing as the problem was with nvidia drivers.

Note You need to log in before you can comment on or make changes to this bug.