Bug 1590462 - missing StartupWMClass=konversation in .desktop file
Summary: missing StartupWMClass=konversation in .desktop file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: konversation
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-12 15:51 UTC by Langdon White
Modified: 2018-07-12 13:47 UTC (History)
2 users (show)

Fixed In Version: konversation-1.7.5-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-11 20:20:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Langdon White 2018-06-12 15:51:44 UTC
Description of problem:
If using gnome and you "favorite" konversation and then start konversation, you end up with two icons (the favorite and the running) in the sidebar. 

Version-Release number of selected component (if applicable):
1.7.4-3.fc28 

How reproducible:
always

Fix (would have made a PR if I could have):
The problem is that the .desktop file does not have the same name as the WMClass. As a result, you need to add StartupWMClass=konversation in the [Desktop Entry] block.

Comment 1 Rex Dieter 2018-06-22 20:01:42 UTC
konversation dev says this is likely a bug or misfeature in gnome not to get that right, but adding an explicit StartupWMClass shouldn't hurt anything either.

Comment 2 Fedora Update System 2018-07-03 21:21:23 UTC
konversation-1.7.5-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-83195e5c58

Comment 3 Fedora Update System 2018-07-03 21:21:56 UTC
konversation-1.7.5-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4a51c00e0a

Comment 4 Fedora Update System 2018-07-04 16:23:34 UTC
konversation-1.7.5-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4a51c00e0a

Comment 5 Fedora Update System 2018-07-04 18:22:25 UTC
konversation-1.7.5-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-83195e5c58

Comment 6 Fedora Update System 2018-07-11 20:20:45 UTC
konversation-1.7.5-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2018-07-12 13:47:09 UTC
konversation-1.7.5-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.