Bug 1590507 - Install fails - Control plane pods didn't come up: applying cgroup configuration for process caused "No such device or address"
Summary: Install fails - Control plane pods didn't come up: applying cgroup configur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.0
Assignee: Jhon Honce
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-12 17:36 UTC by Vikas Laad
Modified: 2018-08-15 13:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log with -vvv (1.35 MB, text/plain)
2018-06-12 17:39 UTC, Vikas Laad
no flags Details
master journal logs (1.35 MB, application/zip)
2018-06-12 17:41 UTC, Vikas Laad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:18:17 UTC

Description Vikas Laad 2018-06-12 17:36:09 UTC
Description of problem:
Installing openshift v3.10.0-0.66 fails, control plan pods dont come up ok.

Version-Release number of selected component (if applicable):
openshift v3.10.0-0.66

Client:
 Version:         1.13.1
 API version:     1.26
 Package version: docker-1.13.1-66.gitdded712.el7.x86_64
 Go version:      go1.9.2
 Git commit:      dded712/1.13.1
 Built:           Mon Jun 11 11:42:40 2018
 OS/Arch:         linux/amd64

Server:
 Version:         1.13.1
 API version:     1.26 (minimum version 1.12)
 Package version: docker-1.13.1-66.gitdded712.el7.x86_64
 Go version:      go1.9.2
 Git commit:      dded712/1.13.1
 Built:           Mon Jun 11 11:42:40 2018
 OS/Arch:         linux/amd64
 Experimental:    false

How reproducible:
with build v3.10.0-0.66

Steps to Reproduce:
1. Use attached inventory to install v3.10.0-0.66
2. see ansible and journal logs attached.

Actual results:
Install fails because control plane pods didn't come up

Expected results:
Install should complete

Additional info:

Comment 2 Vikas Laad 2018-06-12 17:39:12 UTC
Created attachment 1450585 [details]
ansible log with -vvv

Comment 3 Vikas Laad 2018-06-12 17:41:29 UTC
Created attachment 1450586 [details]
master journal logs

Comment 4 Mike Fiedler 2018-06-12 17:46:57 UTC
From the journal:

Jun 12 17:27:01 ip-172-31-50-118.us-west-2.compute.internal dockerd-current[2960]: time="2018-06-12T17:27:01.62026041Z" level=error msg="containerd: start container" error="oci runtime error: container_linux.go:247: starting container process caused \"process_linux.go:258: applying cgroup configuration for process caused \\\"No such device or address\\\"\"\n" 

id=ed4f17954b558e1089b8f09f9e6f2c51a79ff1d51dd8c046f4a6641d10daa745
Jun 12 17:27:01 ip-172-31-50-118.us-west-2.compute.internal dockerd-current[2960]: time="2018-06-12T17:27:01.620586168Z" level=error msg="Create container failed with error: oci runtime error: container_linux.go:247: starting container process caused \"process_linux.go:258: applying cgroup configuration for process caused \\\"No such device or address\\\"\"\n"

Comment 5 Mrunal Patel 2018-06-12 20:46:59 UTC
Can we retry with the latest docker build https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=709971?

Comment 7 Vikas Laad 2018-06-13 13:26:41 UTC
Works with following docker version

docker.x86_64                 2:1.13.1-68.gitdded712.el7

Comment 9 errata-xmlrpc 2018-07-30 19:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.