Bug 159056 - ntpd segfaults when loopif is unconfigured
ntpd segfaults when loopif is unconfigured
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
https://ntp.isc.org/bugs/show_bug.cgi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-28 05:55 EDT by Christiaan Simons
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 04:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ntp-4.2.0.a.20050816-2.src.rpm (incl. traces) (3.94 MB, text/plain)
2006-01-20 06:25 EST, Petr Raszyk
no flags Details

  None (edit)
Description Christiaan Simons 2005-05-28 05:55:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When trying to start ntpd without a configured 'lo' interface it crashes. This is an odd situation, which will typically not occur. It was reported to ntp.org
coders as case 420.

Version-Release number of selected component (if applicable):
4.1 and 4.2

How reproducible:
Always

Steps to Reproduce:
1. No daemon in background.
2. Unconfigure your loop if, (no IP, but UP!).
3. run ntpd -d (debug mode)
  

Actual Results:  Segmentation fault after a few seconds, not immediatly.

Expected Results:  It should complian about loopif being unavailable.

Additional info:
Comment 1 Petr Raszyk 2006-01-20 06:25:20 EST
Created attachment 123475 [details]
ntp-4.2.0.a.20050816-2.src.rpm (incl. traces)

Can you compile and install ntp-4.2.0.a.20050816-2.src.rpm above ?
Can you 'run' ntpd in your scenario ?
It creates (3-4) /tmp/ntpd*.PID files.
It contains autotrace+autodebug informations.
Please, can you send me these files ?
Comment 2 Miroslav Lichvar 2006-02-23 04:56:58 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.