Bug 1590662 - "ERROR: logging before flag.Parse" appears in each line of the pod logs
Summary: "ERROR: logging before flag.Parse" appears in each line of the pod logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-13 07:39 UTC by Meng Bo
Modified: 2018-07-30 19:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:18:17 UTC

Description Meng Bo 2018-06-13 07:39:28 UTC
Description of problem:
Setup ocp cluster, check the pod/container log via oc logs or docker logs

There are lots of error:
ERROR: logging before flag.Parse: I0613 07:17:30.918765       1 trace.go:76] Trace[2117446776]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.59974022 +0000 UTC m=+113.276002487) (total time: 1.319002886s):
Trace[2117446776]: [1.319002886s] [1.318995279s] END
ERROR: logging before flag.Parse: I0613 07:17:30.918908       1 trace.go:76] Trace[1969766476]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.599082562 +0000 UTC m=+113.275344827) (total time: 1.319800289s):
Trace[1969766476]: [1.319800289s] [1.319792743s] END
ERROR: logging before flag.Parse: I0613 07:17:30.919099       1 trace.go:76] Trace[1338281318]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.598142921 +0000 UTC m=+113.274405188) (total time: 1.320927093s):
Trace[1338281318]: [1.320927093s] [1.320919899s] END
ERROR: logging before flag.Parse: I0613 07:17:30.919283       1 trace.go:76] Trace[2079055206]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.597517895 +0000 UTC m=+113.273780443) (total time: 1.321739729s):
Trace[2079055206]: [1.321739729s] [1.321728241s] END


Version-Release number of selected component (if applicable):
v3.10.0-0.67.0

How reproducible:
always

Steps to Reproduce:
1. Setup ocp cluster
2. Check the master api pod log or the sdn pod log
3.

Actual results:
There are lots of error:
ERROR: logging before flag.Parse: I0613 07:17:30.918765       1 trace.go:76] Trace[2117446776]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.59974022 +0000 UTC m=+113.276002487) (total time: 1.319002886s):
Trace[2117446776]: [1.319002886s] [1.318995279s] END
ERROR: logging before flag.Parse: I0613 07:17:30.918908       1 trace.go:76] Trace[1969766476]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.599082562 +0000 UTC m=+113.275344827) (total time: 1.319800289s):
Trace[1969766476]: [1.319800289s] [1.319792743s] END
ERROR: logging before flag.Parse: I0613 07:17:30.919099       1 trace.go:76] Trace[1338281318]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.598142921 +0000 UTC m=+113.274405188) (total time: 1.320927093s):
Trace[1338281318]: [1.320927093s] [1.320919899s] END
ERROR: logging before flag.Parse: I0613 07:17:30.919283       1 trace.go:76] Trace[2079055206]: "Get /api/v1/namespaces/openshift-web-console/configmaps/webconsole-config" (started: 2018-06-13 07:17:29.597517895 +0000 UTC m=+113.273780443) (total time: 1.321739729s):
Trace[2079055206]: [1.321739729s] [1.321728241s] END


Expected results:
Should not have such errors.

Additional info:

Comment 2 Seth Jennings 2018-06-13 17:09:46 UTC
Origin PR:
https://github.com/openshift/origin/pull/19994

Comment 4 Meng Bo 2018-06-20 06:43:18 UTC
Cannot see the errors on build v3.10.0-0.69.0

Verify the bug

Comment 6 errata-xmlrpc 2018-07-30 19:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.