Bug 159072 - Application "gpilotd" (in FC5 was in FC4 also) crashes as soon as Cradle Sync Button is pressed
Application "gpilotd" (in FC5 was in FC4 also) crashes as soon as Cradle Syn...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
http://noldata.com/i686
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-05-28 12:57 EDT by Gustavo A. Lozano
Modified: 2007-11-30 17:11 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 18:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo A. Lozano 2005-05-28 12:57:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Components:
Palm Tungsten T2, via USB Cradle (Worked like a charm with FC2 and FC3)
Fedora Core 4 Test 3

When trying to configure for the first time the gnome-pilot software (by adding the gnome-pilot applet and then following the instructions), it works fine until it asks for pressing the sync button in the cradle.

As soon as the button is pressed, the gpilotd crashes.
dmesg shows only this:

usb 2-2: new full speed USB device using ohci_hcd and address 4
visor 2-2:1.0: Handspring Visor / Palm OS converter detected
usb 2-2: Handspring Visor / Palm OS converter now attached to ttyUSB0
usb 2-2: Handspring Visor / Palm OS converter now attached to ttyUSB1

visor ttyUSB0: Handspring Visor / Palm OS converter now disconnected from ttyUSB0
visor ttyUSB1: Handspring Visor / Palm OS converter now disconnected from ttyUSB1
visor 2-2:1.0: device disconnected



Version-Release number of selected component (if applicable):
gnome-pilot-2.0.13-2

How reproducible:
Always

Steps to Reproduce:
1. Add the pilot applet
2. follow the instructions until it asks for a sync to get the user id from the Handheld
3. see the crash
  

Actual Results:  Window saying gpilotd has quit unexpectedly

Expected Results:  user id listed from the handheld

Additional info:
Comment 1 Fernando Fernandez Pedraza 2005-05-30 17:00:25 EDT
I've had exactly the same problem, following exacly the same steps.
My PDA is a Treo 600.
Comment 2 François Jan 2005-06-02 15:46:52 EDT
Same here with TH55 and FC4 test3

Comment 3 Ralf Spenneberg 2005-06-20 09:26:05 EDT
Still the same using Treo 600/USB/FC4.

More information:

Distribution: Fedora Core release 4 (Stentz)
Package: gnome-pilot
Severity: normal
Version: GNOME2.10.0 unspecified
Gnome-Distributor: Red Hat, Inc
Synopsis: gpilotd crashes on Sync
Bugzilla-Product: gnome-pilot
Bugzilla-Component: gpilotd
Bugzilla-Version: unspecified
BugBuddy-GnomeVersion: 2.0 (2.10.0)
Description:
Description of the crash:
When syncing using USB gpilot crashes.

Steps to reproduce the crash:
1. Start gpilotd
2. Press hotsync on the treo600
3. gpilotd crashes

Expected Results:
Sync.

How often does this happen?
Everytime

Additional Information:
Commandline-Output:
$  /usr/libexec/gpilotd
gpilotd-Message: gnome-pilot 2.0.13 starting...
gpilotd-Message: compiled for pilot-link version 0.12.0-pre2
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]

(gpilotd:5700): gpilotd-WARNING **: Gerät Irda (/dev/ircomm0) konnte
nicht geöffnet werden: Grund: "Keine Berechtigung".
gpilotd-Message: Activating CORBA server
gpilotd-Message: bonobo_activation_active_server_register = 0
gpilotd-Message: USB (/dev/pilot) wird betrachtet
gpilotd-Message: Found 4766, 0001
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0502, 0736
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 091e, 0004
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 082d, 0100
gpilotd-Message: Using net FALSE
gpilotd-Message: Found 082d, 0200
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 082d, 0300
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0c88, 0021
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0001
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0002
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0003
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0020
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0031
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0040
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0050
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0060
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0061
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0070
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 0830, 0080
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 04e8, 8001
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 04e8, 6601
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 0038
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 0066
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 0095
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 009a
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 00c9
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 00da
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 00e9
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 0144
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 054c, 0169
gpilotd-Message: Using net TRUE
gpilotd-Message: Found 12ef, 0100
gpilotd-Message: Using net TRUE
gpilotd-Message: setting PILOTRATE=57600

<crash>




Debugging Information:

Backtrace was generated from '/usr/libexec/gpilotd'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208535360 (LWP 5700)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00834402 in ?? ()
#0  0x00834402 in ?? ()
#1  0x0011bf93 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x0204c080 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0069ef68 in pi_listen () from /usr/lib/libpisock.so.9
#5  0x0804cf4d in device_equal_by_io ()
#6  0x0804e2f0 in network_device_err ()
#7  0x003bef06 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
#8  0x003bd3ee in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#9  0x003c03f6 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
#10 0x003c08d8 in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
#11 0x0804ecdb in main ()

Thread 1 (Thread -1208535360 (LWP 5700)):
#0  0x00834402 in ?? ()
No symbol table info available.
#1  0x0011bf93 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0204c080 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0069ef68 in pi_listen () from /usr/lib/libpisock.so.9
No symbol table info available.
#5  0x0804cf4d in device_equal_by_io ()
No symbol table info available.
#6  0x0804e2f0 in network_device_err ()
No symbol table info available.
#7  0x003bef06 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x003bd3ee in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x003c03f6 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x003c08d8 in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#11 0x0804ecdb in main ()
No symbol table info available.
Comment 4 Clark T. 2005-06-24 10:08:27 EDT
Having the same problem with a Treo 90, though I'm able to sync with JPilot. I'd
be happy to do any tests or debugging as needed. This is a feature I'd love to
have access to again.
Comment 5 Vic Ricker 2005-06-24 19:40:07 EDT
I have the same problem with a Treo 650/USB on x86_64.
Comment 6 Josh More 2005-06-29 21:12:05 EDT
I have the same issue with a Treo 600/USB on i386
Comment 7 Joe E. 2005-07-02 03:56:22 EDT
I have the same problem on a Treo 650 with USB.  I'm running FC4 (not a test
build) on a Dell Inspiron 4000.  Haven't played with pilot-xfer or jpilot yet,
but this worked in FC3.
Comment 8 Johnny Proton 2005-07-06 11:53:09 EDT
I have the same issue with a Treo 650/USB on Compaq Presario v2000.  It actually
worked in FC3, but gpilotd would crash on the first sync to Evo, then the second
time it would work well.
Comment 9 Wim Van Bakel 2005-07-07 03:47:01 EDT
I have this problem too. FC4 final and a Palm Zire (m150). In FC3 it just
worked. I desperately want to sync between the Pilot and Evolution so a fix
would be very appreciated.
Comment 10 Rahul Sundaram 2005-07-07 04:57:53 EDT

Moving version to FC4 as per last comment
Comment 11 Fernando Fernandez Pedraza 2005-07-08 12:52:07 EDT
This bug seems to be very important for handheld users, many of us are not able
to sync with our desktops. I suggest changing priority to high.

Comment 12 Gustavo A. Lozano 2005-07-08 14:48:25 EDT
I am the submitter, so I tried to change the priority a few times, but it have
been impossible, the bugzilla is not letting me do it.

Gustavo
Comment 13 Johnny Proton 2005-07-08 15:52:39 EDT
I agree, this should be a high priority bug!  I just missed a meeting yesterday
because my Fedora does not sync to my Treo.  People on other distros (SUSE)
always claim to be able to sync without a problem, yet Fedora has consistent
problems w/ Palm syncing on every release.
Comment 14 B.J. McClure 2005-07-11 18:49:16 EDT
Identical issue with Tungsten T.  Played fine with FC1 through FC3. 
Gnome/Evolution.
Comment 15 Edward Grace 2005-07-12 16:04:18 EDT
Essentially the same issues with Handspring Visor.  pilot-xfer works ok, but
gpilotd fails.

Also kpilot fails to work where it used to (FC2).  Makes me think this is a more
fundemental problem than it appears.
Comment 16 David Zakar 2005-07-19 11:23:08 EDT
Same problem here - try to sync the Fossil FX2008 wrist PDA (PalmOS 4.1), and
gpilotd hits the floor. I've never made it work in FC3 or FC4 (same bug, every
time), but I can't say anything about FC2 or FC1. I've toyed with trying other
distros to see if they have the issue, but haven't done so yet.

Additionally, pilot-xfer does work, interestingly enough.

Definitely is a serious bug - I hate having to run back to Windows / Palm
Desktop to sync my PDA, especially when Evolution is my primary
email/contacts/datebook program. I had assumed the problem was with my weird
hardware - guess not.
Comment 17 Norbert 2005-07-24 09:51:07 EDT
Same issue with my Treo300. Is someone working on fixing the bug? Will we ever
get a new rpm?
Comment 18 Andy Otwell 2005-07-29 17:59:08 EDT
My Treo 650 is dead and ttyUSB0/1 have to be manually created. Also, ttyUSB0/1
disappear after failed sync tests.

AO
Comment 19 Johnny Proton 2005-08-10 14:07:35 EDT
This bug (158809) seems to be the source of our pain.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158809

Seems there was some activity on triage related to this by Dave Jones. Should
this  bug be merged as well?
Comment 20 enricog 2005-08-16 16:31:33 EDT
Same problem with a m515 and FC4 x86_64
Comment 21 Ken 2005-09-08 11:51:43 EDT
Getting same error. FC4, Treo 650.
Comment 22 Jean-Francois Saucier 2005-11-15 16:42:05 EST
What's up here?

I have the same problem with Zire 71 and all the lastest package... So, no
Fedora dev use a Palm and sync it? Since the early FC4 test release this problem
occur.

Please fix it... This is a big pain for everyone using Fedora at work.

Thanks a lot
Comment 23 Johnny Proton 2005-11-15 17:32:23 EST
It seems this bug is just ignored by the developers.  Does anyone know if maybe
this is the wrong Bugzilla to be reporting this in?  Should we use Gnome Bugzilla?

Does this occur on anyone else's distro?
Comment 24 Gustavo A. Lozano 2005-11-21 10:04:22 EST
I decided to take a look back on this bug, since its been a long time after my
last palm sync. Digging in google, resulted to this:
http://bellet.info/advogato/person/fab/

I dont know if that works, I am going to test it now, but I wanted to share the
info anyways.

Gustavo
glozano at noldata dot com
Comment 25 Gustavo A. Lozano 2005-11-21 10:34:11 EST
People: I have fixed this bug in my laptop just a couple of minues ago.

Procedure:

Grab the source rpm for pilot-link from FC3
rpmbuild and install it.

Grab the BINARY rpm f gnome-pilot from FC3, and install it

After these 2 steps I have:
pilot-link-0.11.8-8
gnome-pilot-2.0.12-4


Then, follow the standard procedure to add the applet to the panel and have fun!

Gustavo
glozano at noldata dot com
Comment 26 Johnny Proton 2005-11-21 16:18:24 EST
Did you get this also working with Evolution?  I don't know how to remove my
current version of gnome-pilot since Evo is a dependency.

Doesn't really seem this is "fixed" to me...
Comment 27 Gerard Llobet 2005-11-28 12:43:39 EST
Gustavo, I followed what you did and it doesn't work here. Pilot-link still
gives me a buffer-overflow most of the times and only sometimes it work properly.
With respect to gnome-pilot, it does not crash as with version 2.0.13 but it
essentially ignores me.

Gerard
Comment 28 Gustavo A. Lozano 2005-11-28 13:33:23 EST
Here is working fine, but evoution conduits are not being showed in the conduit
list, even after re-compiling it...

I will put my hands over this again, in the weekend and will let you know all
the results.
Comment 29 Matt Davey 2006-01-21 08:00:33 EST
Re comment #28: Where did the evolution package / "make install" put
the ".conduit" files, and are they in the same place as the gnome-pilot
ones?  I've seen some recent confusion over this, with some .conduit
files being put under /usr/lib rather than the usual /usr/share...

I've no comment on the udev issues (comment #19), but if you're having
problems with gpilotd crashing, you should:
0. see if you can downgrade gnome-pilot / pilot-link by recompiling from
source RPMs from fc3.  The fc4 packages were, it has to be said, a disaster,
as they used pre-release pilot-link packages which still had bugs, and had
an utterly incomplete (I guess it compiled, but that was it) attempt to
port gnome-pilot to the new pilot-link API.
1. if that doesn't work for you, try the latest official packages for gnome-
pilot* and pilot-link
2. try configuring 'timeout=0' if you get a 'error occurred while getting the 
pilot's system data' type
3. if all that fails, try installing test packages that may fix some pilot-link/
gnome-pilot bugs that may not have made it into the main distribution. You can 
take a look at http://www.inference.phy.cam.ac.uk/mcdavey/downloads/
Comment 30 Eric Hopper 2006-02-14 08:56:23 EST
This is a problem for me too.  The word FIXED: should be removed from the
summary because it is not fixed.  It isn't fixed until this stops happening with
the stock packages I get from the Fedora project.
Comment 31 Igor Miletic 2006-03-04 16:11:41 EST
This bug still exist on FC5 test3 (using Tungsten T3).

It is not fixed.
Comment 32 Ralph Angenendt 2006-03-05 06:32:16 EST
I can confirm that it still doesn't work on FC5T3 with a Treo600 and USB. I can
sync my Treo with jpilot, but it's a PITA that I'm able to sync with Evolution
at work and have to use jpilot at home. Why is this called fixed?

If more debugging info is needed - please say so. But someone please do
something about this bug.

It *does* work with the versions in RHEL4:

gnome-pilot-2.0.12-4
pilot-link-0.11.8-8

Backtrace of gpilotd after the crash:

0x0016f402 in __kernel_vsyscall ()
(gdb) bt
#0  0x0016f402 in __kernel_vsyscall ()
#1  0x00579546 in kill () from /lib/libc.so.6
#2  0x00cb0626 in _ORBIT_skel_small_GNOME_Pilot_Daemon_reread_config (
    _o_servant=0x805a614, _o_retval=0x0, _o_args=0x0, _o_ctx=0xbfa54448,
    _o_ev=0xbfa5455c,
    _impl_reread_config=0x80537e0 <gpilotd_corba_reread_config>)
    at gnome-pilot-common.c:84
#3  0x0019dee7 in IOP_start_profiles () from /usr/lib/libORBit-2.so.0
#4  0x001a4045 in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
#5  0x001913dc in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0
#6  0x001a1c0e in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#7  0x001a22b2 in ORBit_recv_buffer_return_sys_exception ()
   from /usr/lib/libORBit-2.so.0
#8  0x001a2e03 in ORBit_skel_class_register () from /usr/lib/libORBit-2.so.0
#9  0x001a41e2 in ORBit_handle_request () from /usr/lib/libORBit-2.so.0
#10 0x0018d347 in giop_connection_handle_input () from /usr/lib/libORBit-2.so.0
#11 0x001aad8d in link_connection_state_changed ()
   from /usr/lib/libORBit-2.so.0
#12 0x001adc2e in link_io_add_watch_fd () from /usr/lib/libORBit-2.so.0
#13 0x003bb09d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#14 0x003be32f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#15 0x003be895 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#16 0x0804d274 in main (argc=10057072, argv=0xbfa54894) at gpilotd.c:1092
(gdb) cont
Continuing.

Program received signal SIGABRT, Aborted.
0x0016f402 in __kernel_vsyscall ()
(gdb) bt
#0  0x0016f402 in __kernel_vsyscall ()
#1  0x00579159 in raise () from /lib/libc.so.6
#2  0x0057a6e3 in abort () from /lib/libc.so.6
#3  0x005ada1b in __libc_message () from /lib/libc.so.6
#4  0x0062c8a5 in __chk_fail () from /lib/libc.so.6
#5  0x0062cee8 in __realpath_chk () from /lib/libc.so.6
#6  0x00c8fb19 in pi_serial_bind (ps=0x9ab3800, addr=0xbfa53aca, addrlen=258)
    at /usr/include/bits/stdlib.h:35
#7  0x00c91f25 in pi_bind (pi_sd=37, port=0x9ab37f0 "/dev/pilot")
    at socket.c:1063
#8  0x0804d75e in sync_device (device=0x9ab34f0, context=0x9a93d28)
    at gpilotd.c:166
#9  0x0804e748 in visor_devices_timeout (data=0x9a93d28) at gpilotd.c:912
#10 0x003bb7b6 in g_source_get_current_time () from /usr/lib/libglib-2.0.so.0
#11 0x003bb09d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0x003be32f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#13 0x003be895 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#14 0x0804d274 in main (argc=Cannot access memory at address 0x6
) at gpilotd.c:1092
(gdb) bt f
#0  0x0016f402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00579159 in raise () from /lib/libc.so.6
No symbol table info available.
#2  0x0057a6e3 in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x005ada1b in __libc_message () from /lib/libc.so.6
No symbol table info available.
#4  0x0062c8a5 in __chk_fail () from /lib/libc.so.6
No symbol table info available.
#5  0x0062cee8 in __realpath_chk () from /lib/libc.so.6
No symbol table info available.
#6  0x00c8fb19 in pi_serial_bind (ps=0x9ab3800, addr=0xbfa53aca, addrlen=258)
    at /usr/include/bits/stdlib.h:35
        save_errno = 2
        realport =
"�\000�X�\tD��\000�7�\t;\233�\000�:��u\035�\000\001\000\000\000�7�\t�\000\000\000\000\000\000\000�:���7�\t"
        data = (struct pi_serial_data *) 0x9ab5f68
        err = -502
#7  0x00c91f25 in pi_bind (pi_sd=37, port=0x9ab37f0 "/dev/pilot")
    at socket.c:1063
        bind_return = -201
        ps = (pi_socket_t *) 0x9ab3800
        addr = {pi_family = 0,
  pi_device = "/dev/pilot", '\0' <repeats 244 times>}
#8  0x0804d75e in sync_device (device=0x9ab34f0, context=0x9a93d28)
    at gpilotd.c:166
        pilot = Variable "pilot" is not available.
(gdb)
Comment 33 Johnny Proton 2006-03-05 07:16:18 EST
This bug is NOT FIXED!!!

I've stuck with Fedora and Redhat for a long time now and this has frustrated me
endlessly.  I grew used to syncing my contacts and now I can't even do that.  My
Treo is worthless and it particularly irks me that it used to work great but now
can't operate at all.  Please tell me this will be fixed for FC5.

I will switch to Novell if they get this right.  I am a web developer and this
should be a selling point for linux servers and the enterprise, yet I can't even
perform a simple task like syncing my Treo and my OS.  Please fix this.

Sincerely,

One very concerned Fedora fanatic.

-johnnyproton-
Comment 34 Matt Davey 2006-03-05 08:42:36 EST
Re. comment #32, this stack trace is an instance of a pilot-link bug:
http://bugs.pilot-link.org/1591
The good news is that this bug (and others) have been fixed by the
pilot-link team and will appear in the next release of the pilot-link
suite, whenever it appears.
Comment 35 Johnny Proton 2006-03-06 20:54:19 EST
Matt, do you have any idea when the next release will be?  The last one was June
2005.

More importantly, will this bug exist in FC5?  That's really all most of us care
about, I expect.
Comment 36 Matt Davey 2006-03-07 04:06:21 EST
No, I don't know, but I don't think it is far off.  I'm going by a recent
message by the maintainer to the pilot-link-devel list:
http://lists.pilot-link.org/pipermail/pilot-link-devel/2006-February/001527.html

gnome-pilot CVS is in good shape.  We are essentially ready to do
a release.  I'd like to wait until there's a pilot-link release too, so that
we can clear up the maximum number of problems in one go.

Note that many distributions are happily running with pilot-link 0.11.8 and
gnome-pilot 2.0.13, which you should be able to downgrade to in the meantime
(although I accept that's a bit of hassle, and may require rebuilding
evolution or downgrading that too).
Comment 37 Johnny Proton 2006-03-24 20:02:06 EST
I just installed Fedora 5 this week.  Guess what: still broken!  Still!

Matt, I understand what you guys would like to do.  However, there's also a big
picture thing going on which I feel has been COMPLETELY IGNORED: we are losing
converts to Linux!  Look at this bug list:

http://bugzilla.gnome.org/buglist.cgi?query=pilot

See anything interesting?  There are a ton of people who are reporting problems
with gnome-pilot and pilot-link.  I have ABSOLUTELY NO INTEREST in downgrading
Evolution just to get my Treo to sync!  Why would I want to do that?  Why is
this crappy version of the software included in all the distros?  It would have
made more sense to release along with Fedora so the users could install with
minimal pain and have bugfix releases after that.

I can guarantee that 99% of business executives with a pilot would not consider
Linux or Evolution if the sync didn't work.  Now, if it was a minor bug such as
problems with task or something, there may be a case that it's not important. 
But I haven't been able to sync my PDA for 9 MONTHS!  NOTHING AT ALL!

Please excuse my ranting.  I'm admittedly *furious* that something this
important has been overlooked and ignored for so long.  I don't know how to code
C, but I'm one hell of an evangelist.  My company uses Linux all the time and
I've been systematically converting developers over to it.  I've introduced many
people to Linux and preached the open source gospel for years, but this bug here
is just making us all look like fools.

Does anyone out there know how to get a Treo syncing over USB to Fedora 5,
without downgrading my Evolution installation?  If so, I would love to see how
to do it.
Comment 38 Gustavo A. Lozano 2006-03-25 08:30:24 EST
Hi.

As my ISP seems to be filtering torrents, I finished downloading the DVD over
http last night and installed after some backups. I havent connected my Tungsten
Handheld yet, but being this the case, I will put my hands at work again to
solve this one as soon as possible.

There was a couple of solutions to this issue in FC4, one submitted by dont
remember who, which involved re-installing evolution and all the components
involved, that guy provided binary rpms which was pretty good, the other
solution was mine, and involved compiling your own packages, so I think the
first one was better. Anyways, As wrote before, I will try again to fix this,
but I am sorry, it will requiere to install new packages, I will check out about
making a repository for the couple of products involved. But, Fedora Team, solve
this before please!! It has no presentation, some guys not related to the
project giving packages to solve the problems after 9 months and 2 releases of
no attention to the issue.


Gustavo
Comment 39 Gustavo A. Lozano 2006-03-27 13:17:36 EST
For those interested, I started working on this issue.
Already have RPMs for pilot-link and gnome-pilot that dont produce the crash.

I am now doing the work over evolution which needs to be corrected at build time
in order not to use libipsock, or patch the first 2 components to produce it.

I will give more news in the afternoon.

Gustavo
Comment 40 Gilboa Davara 2006-03-27 13:25:12 EST
Thanks.

I assume it'll be pushed in fc5-update-testing once it's done?
Comment 41 Gustavo A. Lozano 2006-03-27 13:35:42 EST
Since I am not a mantainer no, it will not be pushed to the tree.

I will upload it to some website in order to be downloaded with ftp or http, I
am now testing evolution, so I hope to have something uploaded in the next
couple of hours, in order for you guys to test out and give feedback.

Mainly, all the software is the same shipped with FC5 less pilot-link which was
built from the fc3 srpm. on top of that, gnome-pilot and evol* were rebuilt,
(removing all the patches present in gnome-pilot from the spec file).

So, lets wait for some minutes while I do some pretty basic testing and upload
the (S)RPMs.

G.


Comment 42 Kevin Graff 2006-03-29 12:04:06 EST
Just loaded fc5 hoping that the bug was fixed no such luck. Is anyone coming up
with fix. Been wating 2 days for movement.
Comment 43 Matt Davey 2006-03-29 12:26:22 EST
quick comment: no-one here seems to know when fedora will release working
packages.  In the meantime, there are srpms that were published last July that
may well compile for you.  You may need to force the install, because the
package numbers may be less than what is currently shipping with fc5.  For what
it's worth:

http://zeniv.linux.org.uk/pub/people/mark_adams/SRPMS/
and related announcement (comment number 45):
http://bugzilla.gnome.org/show_bug.cgi?id=274032
Comment 44 Gustavo A. Lozano 2006-03-29 15:06:19 EST
I am working on it, but still have some things to clean.

The gnome-pilot software does connect to my handheld, but the evolution conduits
gave me a problem in the first test, I will rebuild my evolution later today I
think, as the previous 3 days I have been pretty busy with my work.

G.
Comment 45 Gustavo A. Lozano 2006-03-29 17:18:49 EST
People.

I have succesfully synced here my contacts.

I am now uploading to my webserver, I hope somebody can build a torrent to
better the download rate..

The site to download the (s)RPMs is http://noldata.com/i686

The .rpm are there, the .src.rpm are being upload as I type this message so it
will take a little time as my outgoing bandwidth is only 17k/sec

Regards

P.S. Setup instructions:

De-install evolution*, gnome-pilot and pilot-link, probably one or two more
packages depend on evolution, de-install them as well, you can re-install them
later.

Install pilot-link, gnome-pilot and evolution-*

Run the druid, and dont worry if you dont see the conduits in the Pilot devices
configuration gui (I will work on that tomorrow).

Run the configuration DRUID, enable the conduits in evolution and have fun.

Please write to bugzilla if you found problems, I am 101% problems will be
found, but I need people to test this. (Please backup your evol contacts and
palm contacts before doing the sync).

DISCLAIMER: I give no guarantee at all this will work, or that this will not
crash your system, shout the mother of your wife or tell your wife you have an
affair... If you loose your life, your system your everthing, you are up to you,
 do whatever you need to keep copies of the information before you install
anything. If you cant live with this, then dont install anything, I am sorry but
I need to take some precautions :)
YOU ARE ON YOUR OWN!, but as soon your monitor explodes please give us some
feedback... anything can happen and I am not responsible for that.

G
Comment 46 Brian Mury 2006-03-29 19:11:50 EST
My Palm m130 syncs ok using your RPM's. Of course, with no conduits, no real
work gets done, but it successfully completes the sync without crashing.

I am still getting occasional freezes as reported in bug 186712
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186712), but that is
probably unrelated.
Comment 47 Gustavo A. Lozano 2006-03-29 19:56:34 EST
The conduits are there, just they are not visible in the palm configuration
tool, but if you go to evolution and select them, then you will be able to sync.

Please do the procedure and let me know, I am now having some trouble here.

Out of 10 syncs only 4 or 5 are working..

I am working over it, but I think some progress is being made.

G.
Comment 48 Matt Davey 2006-03-30 03:43:11 EST
Gustavo - did your .conduit files get installed in the right place?
Check /usr/lib/gnome-pilot/conduits/* v. /usr/share/gnome-pilot/conduits/*
Comment 49 Kevin Graff 2006-03-30 10:00:54 EST
tryed to install your rpms last night. I think I jid something very wrong. my
laptop won't work any more. I'm reinstall fc5 now will try again later. I
unstalled beagle then evolution-devl evolution gnome-pilot-devel gnome-pilot
pilot-link-devel pilot-link. pilot-link had a dep on kpim witch all the kde
calendar and so on . so I din a rpm -e --force pilot-link. Then I instaled your
pilot-link gnome-pilot no trouble so far and last evolution but evolution came
up with all kinds of errors. so then I tryed uninstalling eveloution and rebooting.
I didnt install any of the devel rpm I think that might be what I did worng any
Ideas
Comment 50 Matt Davey 2006-03-30 10:44:11 EST
Kevin - doing 'rpm --force' is obviously to be avoided unless you really know
what you're doing.  You would be better off doing 'rpm -U' to upgrade the
existing packages rather than removing the old packages.

What do you mean by saying your 'laptop won't work any more'.  Do you mean it
can't boot, or you can't use evolution, or something else?

You don't say what errors you got from evolution -- were they failed
dependencies or runtime errors, or what?

You don't say which RPMs you were installing: were they from comment 43 or
comment 45 above?

You don't say whether you tried rebuilding from the source packages (SRPMS
directory), or whether you tried installing the pre-built binaries (note that
the binary packages in comment #43 are from last July (i.e. pre fc5)).  If you
used binary packages, it might be worth trying to rebuild binary packages from
the source RPMs: "rpmbuild --rebuild my.src.rpm", for example.

Just some ideas.

Matt
Comment 51 Gustavo A. Lozano 2006-03-30 10:46:16 EST
Probably the KDE dependances were the ones involved who trashed the system.
Try to boot in single user mode or from the DVD and re-install pilot-link,
gnome-pilot, evolution and beagle (from the DVD/Fedora/RPMS).
Then boot normally and see what happens.


G,
Comment 52 Kevin Graff 2006-03-30 11:28:45 EST
tOO lATE FOR THAT! It was a fresh install with no user data on it so I just
started a new Install with formating the hard drive. This time I didn't install
KDE so I will see if that was the Problem. I tryed to install the Binarys source
were not up when I down loaded last night. The couputer would boot up but udev
would say no group tty and I WOULD GET FLASHES OF NO USRE THIS AND NO GROUP
THAT.like ether my passwd was gone or the libs to look them up was missing. I
install from bomment 45
Comment 53 Kevin Graff 2006-03-30 14:02:33 EST
I just finished installing fc5 and your bin rpm. The gnome-pilot was able to get
my pilot user info. But there are no conduits showing or working. Nothing seems
to be synchronizing off my Palm T/X. I have files /usr/lib/gnome-pilot/conduits/
but nothing in the /usr/share/gnome-pilot/conduits/ dir. If there is anything
you would likeme to try let me know crashes are not a problem I have nothing to lose
Comment 54 Gustavo A. Lozano 2006-03-30 14:11:30 EST
Let me do a few more tests and I give you instructions..

G.
Comment 55 Brian Mury 2006-03-30 15:21:39 EST
I just copied the conduits from /usr/lib/gnome-pilot/conduits to
/usr/share/gnome-pilot/conduits after reading Matt Davey's comments. I just
successfully synchronized addres, calendar, memo and todo with Evolution. I'm
just missing the time sync plugin I had in FC4...
Comment 56 Gustavo A. Lozano 2006-03-30 15:25:56 EST
Which plugin?

You are telling you did the sync but you miss the sync...
I Dont understand.

It is nice to read it worked for you.

G.
Comment 57 Gustavo A. Lozano 2006-03-30 15:37:03 EST
Hehe I am missreading, the TIME sync utility... I will dig around.

On other news, I am going to publish a fixed version with the plugins in the
correct location later next week.

I will work over it in the weekend.

G.
Comment 58 Kevin Graff 2006-03-30 15:44:12 EST
I also was able to sync after I copyed all the files from
/usr/lib/gnome-pilot/conduits to /usr/share/gnome-pilot/conduits don't know if
all are needed there or just some but it worked
Comment 59 Kevin Graff 2006-03-31 10:20:27 EST
I tryed to do a manule yum update and skip your packages but it would not even
let me get that far. After down loading headers it errored out with 
Error: Missing Dependency: libpisock.so.8 is needed by package evolution
Error: Missing Dependency: libpisock.so.8 is needed by package gnome-pilot
is some way to tel it to skip these packages or can you and the libpisock.so.8
into your rpm?
Thanks
Comment 60 Gustavo A. Lozano 2006-03-31 12:00:40 EST
libpisock.8 is part of pilot-link.

Please install that before, I think you forget to exclude pilot-link at the time
of the update.

Gustavo
Comment 61 Gustavo A. Lozano 2006-03-31 17:01:31 EST
Everybody

I just uploaded the fixed versions of evolution-* which now include the conduits
in the right place.

Get them from http://noldata.com/i686

Regards

Gustavo
Comment 62 Kevin Graff 2006-03-31 17:46:04 EST
You can get packages with evolution fix at
http://linux.buffalowelding.com/i686
along with bittorrent
I hope the bittorrent works never made one before if not let me know
Comment 63 Ricardo Jurczyk Pinheiro 2006-04-01 13:22:46 EST
I've got a X86_64 FC5 box, so does anybody can upload the SRPMS packages too, or
even the x86_64 RPM packages? Thanks in advance.

BTW, I've tried almost everything, even compiled an older pilot-link, in order
to sync to my T|X. Unfortunately, I could not sync. Any ideas? I'm out of them.
Comment 64 Gustavo A. Lozano 2006-04-01 18:48:08 EST
Ricardo.

The source packages are in my website also: http://noldata.com/i686

I uploaded them 4 days ago but forget to include them in the index.html

Regards

Gustavo
Comment 65 Gustavo A. Lozano 2006-04-12 16:32:31 EDT
Everybody.

I just uploaded some other conduits that are usefull to the same site:
http://noldata.com/i686 

Currently I dont have a Handheld anymore so I cannot test them, hopefully you
can test and provide feedback.

Also,  I have a wish list in Amazon Just in case (you neer know), Anybody wants to 
send something :) (I repeat, just in case)

http://www.amazon.com/gp/registry/registry.html/ref=wlem-si-html_viewall/103-6664433-7231020?id=3ULXCX6APTWJD


as new versions of evolution and the related pilot modules are released, I will
continue to update the packages. In the near future, I am planning to setup a
yum repository and jump the package versions in order for everybody to perform a
clean "yum update" without needing to include --exclude=evolution* etc etc.

Regards


Gustavo
Comment 66 Gustavo A. Lozano 2006-04-12 17:38:08 EDT
Hi.

A yum repository is now in place.
Please create a file called /etc/yum.repos.d/noldata-rpms.repo including the next:
[noldata-rpms]
name=Fedora Core 5 - i686 - Noldata RPMS
baseurl=http://noldata.com/i686


after that, yum is ready to use the repository to download and install the files.

Also, gnome-pilot-conduits for i686 have been just uploaded (the first were for
i386)


Regards

Gustavo
Comment 67 Gustavo A. Lozano 2006-04-14 10:20:16 EDT
Everybody:

Please turn off gpgcheck for noldata-rpms in order for it to work, I forgot to
tell that the last time, here is how the /etc/yum.repos.d/noldata-rpms.repo file
should look:

[noldata-rpms]
name=Fedora Core 5 - i686 - Noldata RPMS
baseurl=http://noldata.com/i686
gpgcheck=0


After that change, the repo will work.

Gustavo
glozano@noldata.com
Comment 68 Gustavo A. Lozano 2006-04-18 14:23:41 EDT
Guys. Seems like the redhat guys fixed the bugs we were experiencing:

Shame over them for not giving credit about the procedure to fix the issue which
was published by at least 4 people including me :P

But good for them for including our fix into their tree...


---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2006-363
2006-04-18
---------------------------------------------------------------------

Product     : Fedora Core 5
Name        : gnome-pilot-conduits
Version     : 2.0.13                      
Release     : 3.FC5.3                  
Summary     : Additional conduits for gnome-pilot
Description :
gnome-pilot is a collection of programs and daemon for integrating
GNOME and the PalmPilot<tm>.

Comment 69 Gilboa Davara 2006-04-18 16:50:59 EDT
At least on my machine, the updates-testing pilot-link 0.11.8 based packages
don't really work.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189294
Comment 70 Gustavo A. Lozano 2006-04-18 16:55:09 EDT
Try the updates from the updates tree, not from testing.

If you can find a mirror, try the fedora.redhat site directly (
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/ )

Probably they will work, if not, continue using my rpms :)

Regards

Gustavo
Comment 71 Gilboa Davara 2006-04-19 02:32:13 EDT
Both updates and updates-testing carry the same versions.

G.
Comment 72 Gilboa Davara 2006-04-19 02:35:06 EDT
Baahh... strike that; Seems that updates got a new version of pilot-link last night.

Testing it now.

Thanks,
Gilboa
Comment 73 Matt Davey 2006-04-19 06:37:14 EDT
Hi Gilboa,
I verified your bug (189294) and submitted a patch.  The problem was that there
was a gnome-pilot patch included in the RPM that causes the crash when built
against pilot-link 0.11.8 (it was written against pilot-link 0.12.0pre2).
With any luck there'll be quick turnaround by fedora on this one.
Comment 74 Gustavo A. Lozano 2006-04-19 08:37:08 EDT
Docs.

Many of you have came to my email reporting some problems. I wanted to show you
a step by step guide to update everything and get the thing working with the
latest packages published by the Fedora guys:

delete pilot-link*, gnome-pilot* and evolution:
rpm -e evolution
rpm -e gnome-pilot-devel
rpm -e gnome-pilot-debuginfo
rpm -e gnome-pilot-conduits
rpm -e gnome-pilot
rpm -e pilot-link-debuginfo
rpm -e pilot-link-devel
rpm -e pilot-link

Re-install everything from the updates repo:

yum --disablerepo=core install pilot-link gnome-pilot
gnome-pilot-conduits evolution

You will need to add the --disablerepo argument to any other
repositories you have, so you can use only the updates repo.


Connect the cradle and sync, if nothing happens, in a terminal run dmesg to see
what port is the cradle binding to.
Probably it will be /dev/ttyUSB0 and 1 or /dev/ttyUSB2 and 3

The problem is sometimes when you sync many times to soon, udev assigns ttyUSB2
instead of ttyUSB0 to the device.

So, wait for a couple of minutes before trying again, and then sync. Please
remember to setup your config druid for pilot according to the USB
specification: go to:

System -> Preferences -> More Preferences -> PalmOs Devices
Click the Devices tab, select your cradle and edit it as needed.

Mine was as follows (I gave my old T2 to my young bro):

Cradle /dev/ttyUSB0 115200 USB


Regards

Gustavo
Comment 75 Gilboa Davara 2006-04-19 09:54:46 EDT
Matt,

Saw your fix.
Thanks.

Gilboa
Comment 76 Gustavo A. Lozano 2006-05-08 18:43:26 EDT
All.

I want to express my gratitude to everybody.
     Thanks to Johnny for the Season 5 of Stargate SG-1
     Thanks to the company for the LifeDrive.

It feels great really.

Note You need to log in before you can comment on or make changes to this bug.