Bug 159081 - Clock runs twice as fast unless noapic is used
Summary: Clock runs twice as fast unless noapic is used
Status: CLOSED DUPLICATE of bug 152170
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-29 02:19 UTC by Kyle R Maxwell
Modified: 2015-01-04 22:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 13:58:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci -vv (11.17 KB, text/plain)
2005-06-05 22:16 UTC, Kyle R Maxwell
no flags Details

Description Kyle R Maxwell 2005-05-29 02:19:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The clock runs twice as fast (e.g. gains 60 minutes in 30 minutes) unless the noapic option is passed to the kernel or APIC is disabled in the BIOS. I'm running an ECS RS480-M motherboard with an Athlon 64 3500+ processor. NTP does not 'hold back' the clock to appropriate time.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1363_FC4

How reproducible:
Always

Steps to Reproduce:
1. Start kernel without noapic and observe the clock.
2. Reboot and pass "noapic" in grub. 

  

Additional info:

Comment 1 eraserman 2005-05-31 18:22:52 UTC
Applying the patch at http://lkml.org/lkml/2005/4/6/206 and passing the
parameter "timerhack" to the kernel solved the problem. This is using FC4 test
3, kernel 2.6.11-1.1366_FC4.

Comment 2 Dave Jones 2005-06-04 05:54:32 UTC
does this box have an nforce chipset by any chance ?

Comment 3 Kyle R Maxwell 2005-06-04 14:03:58 UTC
No, I think it's an MSI-based board. In any case, it's definitely not nForce
(has onboard ATI graphics).

Comment 4 Dave Jones 2005-06-04 22:06:17 UTC
lspci output ?


Comment 5 Kyle R Maxwell 2005-06-05 22:16:54 UTC
Created attachment 115158 [details]
Output of lspci -vv

Comment 6 Romain Muller 2005-06-09 12:20:14 UTC
Have the same problem with my Athlon64 3000+ ... Not an nForce based board. I 
connot disable APIC because it causes a hangup at "Applying seagate errata 
fix" ... 

Comment 7 Kyle R Maxwell 2005-06-09 19:32:17 UTC
Will there be a comment in the release notes for FC4 regarding the issue and the
workaround?

Comment 8 Toshio Kuratomi 2005-06-15 23:56:55 UTC
This sounds like Bug #152170.

The FC4 final kernel (kernel-2.6.11-1.1369) has a boot option no_timer_check
that works for me.  It seems to be implementing a later version of the timerhack
patch referenced earlier in this bug.

Comment 9 Kyle R Maxwell 2005-06-20 13:58:08 UTC
You're right, it is a dupe. Sorry I missed it earlier.

*** This bug has been marked as a duplicate of 152170 ***


Note You need to log in before you can comment on or make changes to this bug.