Bug 1590964 - IcedTea-web fails to run with connection failed after upgrade to Fedora 28
Summary: IcedTea-web fails to run with connection failed after upgrade to Fedora 28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: icedtea-web
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-13 19:12 UTC by Logan Kuhn
Modified: 2019-01-03 05:29 UTC (History)
12 users (show)

Fixed In Version: icedtea-web-1.7.1-11.fc28 icedtea-web-1.7.1-11.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 02:26:34 UTC
Type: Bug


Attachments (Terms of Use)
Log files (7.87 KB, application/x-bzip)
2018-06-14 15:02 UTC, Logan Kuhn
no flags Details
Verbose logs attached (7.94 KB, application/x-gzip)
2018-07-02 15:57 UTC, Logan Kuhn
no flags Details

Description Logan Kuhn 2018-06-13 19:12:59 UTC
Description of problem:
Using IcedTea-web and javaws to launch an IPMI interface worked in Fedora 27, but since upgrading to Fedora 28, it fails with Connection Failed

Version-Release number of selected component (if applicable):
icedtea-web-1.7.1-6.fc28.noarch

How reproducible:
100%

Steps to Reproduce:
1. Launch jnlp file
2. Answer the dialog boxes
3. Wait for failure

Actual results:
Failed laugh of an IPMI window

Expected results:
Window allowing remote control of a server

Additional info:

Comment 1 Jason Tibbitts 2018-06-13 22:24:10 UTC
Is this about a Fedora 28 bug or an EPEL7 bug?  You have filed this against EPEL.

Comment 2 Logan Kuhn 2018-06-13 23:09:02 UTC
My apologies, I'll change it to Fedora.  I'm not sure what component to put it under, so I moved it to java-openjdk-1.8.0 since that's the version I've got installed.

Comment 3 Severin Gehwolf 2018-06-14 09:49:01 UTC
Assigning to correct component, icedtea-web.

Comment 4 jiri vanek 2018-06-14 13:28:19 UTC
There is no info which would allow me to pinpoint the issue. However I'm 100% sure this is casued by new system-wide crypoto policy. 
The used  crypto policies changed between f27 and f28.
You may check by:
update-crypto-policies --show

try update-crypto-policies --set LEGACY for check.

And rerun your application. Please clsoe this if it works.

Comment 5 Logan Kuhn 2018-06-14 15:02:36 UTC
Created attachment 1451444 [details]
Log files

Comment 6 Logan Kuhn 2018-06-14 15:02:57 UTC
Tried that on the freshly upgraded VM and on my usual desktop, it will show the splash screen, it'll go away for a split second and then the splash screen comes back.  When it goes away again it just stays closed and nothing happens.

I've disabled selinux on both systems, reinstalled icedtea-web, still nothing.  I've attached the contents of the log directory, let me know if there is any other information I can provide.

Comment 7 jiri vanek 2018-06-27 13:17:58 UTC
(In reply to Logan Kuhn from comment #5)
> Created attachment 1451444 [details]
> Log files

The log is not tar.gz, but tar only.  A bit confusing...
None of the logs contains traces. Weird.
Can you please run in --verbose mode? And can you please attach only the log form single run?

Is it possible you are using 32b application  on 64b system? Hopefully it will be visible from verbose logs.

Comment 8 Logan Kuhn 2018-07-02 15:57:55 UTC
Created attachment 1455986 [details]
Verbose logs attached

Comment 9 jiri vanek 2018-07-04 13:46:19 UTC
Weird. There is nothing interesting....Is there some easy way I can reproduce locally?
Can you try to downgrade JDK down to oldest in f28? Can you maybe then downgrade to the f27's jdks? Down to the JDK your app was working with?

Maybe some depndence of the native library is missing? I'm really lacking any pointer. Without ay to reproduce I cant fix. And I'm starting to doubt it ITW's issue at all.

Comment 10 Logan Kuhn 2018-07-11 15:04:25 UTC
Here is my test environment.

Fedora 28 Workstation w/Cinnamon, all default install options (https://download.fedoraproject.org/pub/fedora/linux/releases/28/Spins/x86_64/iso/Fedora-Cinnamon-Live-x86_64-28-1.1.iso).  I also tried the default workstation with gnome and it didn't seem to make a difference.

The VM is running via libvirt and managed via virt-manager.  The physical machine is a generic desktop running an Intel Skylake CPU, I can get more specifics if you wish.  The previously suggested crypto changes were enabled once the upgrade to Fedora 28 completed, but I also tested it with it set to DEFAULT

I downgraded icedtea-web and all associated packages to fc27 rpms.  I'm not sure this is actually a permanent solution because of it downgrading system python and systemd as well, but in the interests of testing it.  I did it and it's a VM, so who cares..

This didn't change the behavior.  It still ends up showing "Connection failed" and then terminating.

As far as an ipmi interface goes, I'm not sure how to suggest testing that... Do you have another way for me to test it without using ipmi?

Comment 11 Fedora Update System 2018-12-21 15:17:01 UTC
icedtea-web-1.7.1-11.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0aa0924fa7

Comment 12 Fedora Update System 2018-12-21 15:17:04 UTC
icedtea-web-1.7.1-11.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0fa615ecc

Comment 13 Fedora Update System 2018-12-22 01:33:37 UTC
icedtea-web-1.7.1-11.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0fa615ecc

Comment 14 Fedora Update System 2018-12-22 02:58:25 UTC
icedtea-web-1.7.1-11.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0aa0924fa7

Comment 15 Fedora Update System 2019-01-03 02:26:34 UTC
icedtea-web-1.7.1-11.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-01-03 05:29:23 UTC
icedtea-web-1.7.1-11.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.