Bug 15910 - Inability to test cluster once ipvsadm rule(s) in place
Inability to test cluster once ipvsadm rule(s) in place
Status: CLOSED WORKSFORME
Product: Red Hat High Availability Server
Classification: Retired
Component: documentation (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Phil Copeland
Wil Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 04:30 EDT by David D.W. Downey
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 19:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-10 04:30:02 EDT
Problem: Once ipvdadm rule is in place allowing Virtual server real node to handle requests (in this case WWW requests), you become unable 
to test if the rule works since you can not run the following command from the LVS active node.

while true; do lynx -head http://virtualserver_ip; done

as stated in the documentation.

Workaround: One must telnet/shh to some outside server and run the above command from there.

This escalates the problem to a SEVERE setting if one does not have an outside system from which to run this test. According to the docs this 
command should work FROM the active node and should not require an outside node
Comment 1 Red Hat Bugzilla 2000-08-10 14:47:35 EDT
This works for us. We do it on a regular basis both in the lab and as part of QA
product testing. In all cases, this is done from a client PC, as the request
needs to originate from there to be a valid representation test of a client
request being processed. I'll take a look at applying it to the LVS router and
see if the documentation needs to be corrected on this. If the documentation is
modified as a result, an update will get posted here on bugzilla.

Thanks



Note You need to log in before you can comment on or make changes to this bug.