Bug 159106 - starting X server mangles text console on Thinkpad
Summary: starting X server mangles text console on Thinkpad
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On: libvgahw
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-29 21:34 UTC by Alexander Boström
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 17:13:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg configuration for Savage IX on Thinkpad T22 (FC4) (2.75 KB, application/octet-stream)
2005-06-21 15:41 UTC, wilksen
no flags Details
xorg server log file after text console is garbled (blinking characters) (35.26 KB, text/x-log)
2005-06-21 15:43 UTC, wilksen
no flags Details
xorg.conf from thinkpad t20 (2.75 KB, text/plain)
2005-06-22 22:02 UTC, Michael A. Peters
no flags Details

Description Alexander Boström 2005-05-29 21:34:09 UTC
Description of problem:
After starting the X server, the text consoles display mostly garbage. (The
characters are in the right places (except for some blinking garbage here and
there) and the mouse pointer is visible, but the font and colors are all wrong.)

Fiddling with setfont and switching back and forth between X11 and text console
restores it, except for the text being shifted a few pixels to the left.

Hardware:
IBM Thinkpad T21.
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31
2.6.11-1.1363_FC4 i686

How reproducible:
Always.

Steps to Reproduce:
1. Boot latest FC devel.
2. Wait for GDM.
3. Ctrl-Alt-F1

Comment 1 Michael A. Peters 2005-06-16 00:57:09 UTC
I was seeing that as well with a Thinkpad T20 in rawhide.
In FC4 I am seeing something else - weird colours where the consoles are suppose
to be. Sometimes large bars with one flashing like a huge cursor, sometimes a
purple border around a black blank screen.

IBM Thinkpad T20 (700MHz)

S3 Inc. 86C270-294 Savage/IX-MV

Also - sometimes at boot, it does not bring up X but locks up (machine can't
even be pinged). If it does bring X up though - X is stable for days. Knoppix
does not ever have any issues bringing X up, so it is not hardware issue.

Comment 2 Mike A. Harris 2005-06-17 17:12:18 UTC
Attach X server log and config file from after problem occurs.

Comment 3 wilksen 2005-06-21 15:40:00 UTC
Confirmed here on a Thinkpad T22 with a
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)
on Fedora Core 4 using xorg-x11-6.8.2-37 etc. After bootup X11 comes up
fine, the text console is actually in pink, characters shifted by a few
pixels to the left. The text is readable as long X11 doesn't get restarted.
Then the console gets black as also the text. Sometimes it is completely 
garbled after restarting X11 (e.g. by using ctrl-alt-backspace or init 3 -> 
init 5). The Savage driver was already sort of broken in FC3 and RHEL 4 but
at least the text console was ok. I'm attaching my xorg.conf and log file
after the text console is garbled.

Comment 4 wilksen 2005-06-21 15:41:53 UTC
Created attachment 115750 [details]
xorg configuration for Savage IX on Thinkpad T22 (FC4)

Comment 5 wilksen 2005-06-21 15:43:04 UTC
Created attachment 115751 [details]
xorg server log file after text console is garbled (blinking characters)

Comment 6 wilksen 2005-06-21 15:49:29 UTC
Add-on: the VESA driver runs just fine without disturbing the text console, 
same for RHEL 3 Savage driver (then still XFree86) on the same hardware.

Comment 7 Michael A. Peters 2005-06-22 21:58:57 UTC
For me anyway (thinkpad T20) this bug is clearly a duplicate of bug 161242

01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 11)

my xorg.conf attached

Comment 8 Michael A. Peters 2005-06-22 22:02:10 UTC
Created attachment 115840 [details]
xorg.conf from thinkpad t20

With this xorg.conf - the virtual console is fixed by replacing fc4 libvgahw.a
with the one from fc3

Comment 9 wilksen 2005-06-22 23:48:01 UTC
Second that. Just replacing libvgahw.a from Mike Harris (FC3) fixes the problem 
for me S3 Inc. 86C270-294 Savage/IX-MV (rev 13), too. No other changes applied.

Comment 10 Mike A. Harris 2005-06-23 17:13:45 UTC
The original reporter has not yet responded, but there are enough other
people reporting this problem or very similar problems both in this bug
report and in others, that I'm going to conclude the same thing, and mark
this as a duplicate of bug #161242.

Thanks for the feedback guys!

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.