Bug 1591076 - The driver of 'throttle' is not whitelisted
Summary: The driver of 'throttle' is not whitelisted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-14 02:29 UTC by cliao
Modified: 2018-11-01 11:12 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:10:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:12:30 UTC

Description cliao 2018-06-14 02:29:30 UTC
Description of problem:
The driver of 'throttle' is not whitelisted

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.12.0-3.el7

How reproducible:
100%

Steps to Reproduce:
1.boot guest with -drive driver=throttle:
/usr/libexec/qemu-kvm  \
		-m 8192 \
		-smp 8 \
		-vnc :0 \
		-name guest=test1,debug-threads=on \
		-boot menu=on \
		-device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 \
		-drive file=/home/rhel76-64-virtio-scsi.qcow2,format=qcow2,if=none,id=drive-scsi0-0-0-0 \
		-device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 \
		-device virtio-net-pci,mac=9a:70:71:72:74:73,id=idIBZSw2,vectors=4,netdev=idHrhHM9,bus=pci.0,addr=06,bootindex=3 \
		-netdev tap,id=idHrhHM9,vhost=on \
                -object throttle-group,id=foo,x-iops-total=100 \
                -drive driver=throttle,file.filename=/home/foo.qcow2,throttle-group=bar \
		-monitor stdio -qmp tcp:0:4444,server,nowait


Actual results:
qemu-kvm: -drive driver=throttle,file.filename=/home/foo.qcow2,throttle-group=bar: Driver 'throttle' is not whitelisted

Expected results:
Boot guest successful.

Comment 6 Miroslav Rezanina 2018-07-01 03:25:32 UTC
Fix included in qemu-kvm-rhev-2.12.0-6.el7

Comment 7 cliao 2018-07-02 06:42:01 UTC
The driver is whitelisted.
But the size of data disk in guest is 0 MB

1.boot guest commands:
cat run.sh
/usr/libexec/qemu-kvm  \
		-m 8192 \
		-smp 8 \
		-vnc :0 \
		-name guest=test1,debug-threads=on \
		-boot menu=on \
		-device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 \
		-drive file=/home/rhel76-64-virtio-scsi.qcow2,format=qcow2,if=none,id=drive-scsi0-0-0-0 \
		-device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 \
		-device virtio-net-pci,mac=9a:70:71:72:74:73,id=idIBZSw2,vectors=4,netdev=idHrhHM9,bus=pci.0,addr=06,bootindex=3 \
		-netdev tap,id=idHrhHM9,vhost=on \
                -object throttle-group,id=foo,x-iops-total=100 \
                -drive driver=throttle,file.filename=/home/disk1.qcow2,throttle-group=foo \
		-monitor stdio -qmp tcp:0:4444,server,nowait

2. boot guest:
 ./run2.sh 
QEMU 2.12.0 monitor - type 'help' for more information
(qemu) info block
drive-scsi0-0-0-0 (#block165): /home/rhel76-64-virtio-scsi.qcow2 (qcow2)
    Attached to:      scsi0-0-0-0
    Cache mode:       writeback

ide0-hd0 (#block322): json:{"throttle-group": "foo", "driver": "throttle", "file": {"driver": "file", "filename": "/home/disk1.qcow2"}} (throttle)
    Attached to:      /machine/unattached/device[28]
    Cache mode:       writeback

floppy0: [not inserted]
    Attached to:      /machine/unattached/device[22]
    Removable device: not locked, tray closed

sd0: [not inserted]
    Removable device: not locked, tray closed
(qemu) q

3. check the size of data disk:
fdisk -l

Disk /dev/sdb: 0 MB, 197120 bytes, 385 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 21.5 GB, 21474836480 bytes, 41943040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000015b7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048     2099199     1048576   83  Linux
/dev/sda2         2099200    41943039    19921920   8e  Linux LVM
......

Comment 13 Stefan Hajnoczi 2018-07-17 12:30:01 UTC
I would just consider this a bug.  The driver should have been whitelisted in RHEL so that libvirt can use it (see Comment#5).

Comment 18 errata-xmlrpc 2018-11-01 11:10:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.