Bug 1591191 - several abrt related AVCs
Summary: several abrt related AVCs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-14 09:00 UTC by Martin Krajnak
Modified: 2018-10-30 10:05 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.13.1-205.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:05:41 UTC

Description Martin Krajnak 2018-06-14 09:00:39 UTC
Description of problem: 
We are getting several AVC's in our CI related to abrt, I can provide test machine if required.
More logs can be found here:
https://beaker.engineering.redhat.com/recipes/5268548#task73715373

SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   enforcing
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      31
selinux-policy-3.13.1-203.el7.noarch
----
time->Thu Jun 14 04:43:24 2018
type=PROCTITLE msg=audit(1528965804.374:274): proctitle="(null)"
type=SYSCALL msg=audit(1528965804.374:274): arch=c000003e syscall=59 success=no exit=-13 a0=7fff65f9cf6d a1=7fff65f9b030 a2=555cd6757150 a3=7fff65f99720 items=0 ppid=29340 pid=29811 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-dump-oops" exe="/usr/bin/abrt-dump-oops" subj=system_u:system_r:abrt_watch_log_t:s0 key=(null)
type=AVC msg=audit(1528965804.374:274): avc:  denied  { map } for  pid=29811 comm="abrt-dump-oops" path="/usr/bin/abrt-dump-oops" dev="dm-0" ino=51251619 scontext=system_u:system_r:abrt_watch_log_t:s0 tcontext=system_u:object_r:abrt_dump_oops_exec_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:54 2018
type=PROCTITLE msg=audit(1528965834.083:321): proctitle=2F7573722F6C6962657865632F616272742D686F6F6B2D63637070003500313834343637343430373337303935353136313500333036373100313030300031303030003135323839363538333300650033303637310033303637310071652D64656C6C2D6F7673352D766D2D32382E6471652E6C61622E656E672E626F732E72
type=SYSCALL msg=audit(1528965834.083:321): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=18e48 a2=1 a3=2 items=0 ppid=47 pid=30718 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-hook-ccpp" exe="/usr/libexec/abrt-hook-ccpp" subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)
type=AVC msg=audit(1528965834.083:321): avc:  denied  { map } for  pid=30718 comm="abrt-hook-ccpp" path="/usr/libexec/gsd-account" dev="dm-0" ino=2134284 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:54 2018
type=PROCTITLE msg=audit(1528965834.118:323): proctitle=2F7573722F6C6962657865632F616272742D686F6F6B2D63637070003500313834343637343430373337303935353136313500333036373100313030300031303030003135323839363538333300650033303637310033303637310071652D64656C6C2D6F7673352D766D2D32382E6471652E6C61622E656E672E626F732E72
type=SYSCALL msg=audit(1528965834.118:323): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=18e48 a2=3 a3=2 items=0 ppid=47 pid=30718 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-hook-ccpp" exe="/usr/libexec/abrt-hook-ccpp" subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)
type=AVC msg=audit(1528965834.118:323): avc:  denied  { map } for  pid=30718 comm="abrt-hook-ccpp" path="/usr/libexec/gsd-account" dev="dm-0" ino=2134284 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:56 2018
type=PROCTITLE msg=audit(1528965836.636:326): proctitle="(null)"
type=SYSCALL msg=audit(1528965836.636:326): arch=c000003e syscall=59 success=no exit=-13 a0=56126d4c4f80 a1=56126d4c4690 a2=56126d4c3060 a3=2 items=0 ppid=30961 pid=30962 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-dbus" exe="/usr/sbin/abrt-dbus" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965836.636:326): avc:  denied  { map } for  pid=30962 comm="abrt-dbus" path="/usr/sbin/abrt-dbus" dev="dm-0" ino=1379982 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_exec_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:57 2018
type=PROCTITLE msg=audit(1528965837.136:328): proctitle="(null)"
type=SYSCALL msg=audit(1528965837.136:328): arch=c000003e syscall=59 success=no exit=-13 a0=55f6a4542f80 a1=55f6a4542690 a2=55f6a4541060 a3=2 items=0 ppid=30984 pid=30985 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-dbus" exe="/usr/sbin/abrt-dbus" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965837.136:328): avc:  denied  { map } for  pid=30985 comm="abrt-dbus" path="/usr/sbin/abrt-dbus" dev="dm-0" ino=1379982 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_exec_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:57 2018
type=PROCTITLE msg=audit(1528965837.242:329): proctitle=2F7573722F62696E2F707974686F6E002D75002F7573722F62696E2F616272742D616374696F6E2D696E7374616C6C2D6465627567696E666F002D79
type=SYSCALL msg=audit(1528965837.242:329): arch=c000003e syscall=2 success=no exit=-13 a0=2746210 a1=441 a2=1b6 a3=24 items=0 ppid=30963 pid=30981 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-action-ins" exe="/usr/bin/python2.7" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965837.242:329): avc:  denied  { open } for  pid=30981 comm="abrt-action-ins" path="/var/log/rhsm/rhsm.log" dev="dm-0" ino=50331723 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:rhsmcertd_log_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:57 2018
type=PROCTITLE msg=audit(1528965837.244:330): proctitle=2F7573722F62696E2F707974686F6E002D75002F7573722F62696E2F616272742D616374696F6E2D696E7374616C6C2D6465627567696E666F002D79
type=SYSCALL msg=audit(1528965837.244:330): arch=c000003e syscall=2 success=no exit=-13 a0=275b9d0 a1=241 a2=1b6 a3=24 items=0 ppid=30963 pid=30981 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-action-ins" exe="/usr/bin/python2.7" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965837.244:330): avc:  denied  { write } for  pid=30981 comm="abrt-action-ins" name="rhsm" dev="tmpfs" ino=14747 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:rhsmcertd_var_run_t:s0 tclass=dir permissive=0
----
time->Thu Jun 14 04:43:56 2018
type=PROCTITLE msg=audit(1528965836.626:325): proctitle="(null)"
type=SYSCALL msg=audit(1528965836.626:325): arch=c000003e syscall=59 success=no exit=-13 a0=5595d8ce1f80 a1=5595d8ce1690 a2=5595d8ce0060 a3=2 items=0 ppid=30959 pid=30960 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-dbus" exe="/usr/sbin/abrt-dbus" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965836.626:325): avc:  denied  { map } for  pid=30960 comm="abrt-dbus" path="/usr/sbin/abrt-dbus" dev="dm-0" ino=1379982 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_exec_t:s0 tclass=file permissive=0
----
time->Thu Jun 14 04:43:57 2018
type=PROCTITLE msg=audit(1528965837.131:327): proctitle="(null)"
type=SYSCALL msg=audit(1528965837.131:327): arch=c000003e syscall=59 success=no exit=-13 a0=55d9f37f0f80 a1=55d9f37f0690 a2=55d9f37ef060 a3=2 items=0 ppid=30982 pid=30983 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-dbus" exe="/usr/sbin/abrt-dbus" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1528965837.131:327): avc:  denied  { map } for  pid=30983 comm="abrt-dbus" path="/usr/sbin/abrt-dbus" dev="dm-0" ino=1379982 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:abrt_exec_t:s0 tclass=file permissive=0

Version-Release number of selected component (if applicable):
kernel-3.10.0-902.el7.x86_64
selinux-policy-3.13.1-203.el7.noarch
selinux-policy-targeted-3.13.1-203.el7.noarch

How reproducible:
always

Comment 5 errata-xmlrpc 2018-10-30 10:05:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.