This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 159153 - Unable to use spadmin to redefine a CUPS printer as a fax device
Unable to use spadmin to redefine a CUPS printer as a fax device
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
http://qa.openoffice.org/issues/show_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-30 14:46 EDT by Brian Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.104-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-14 05:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 49980 None None None Never

  None (edit)
Description Brian Johnson 2005-05-30 14:46:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
The url to the issue report in the openoffice project explains it all

They say it is a problem created by Fedora


Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-11.5.0.fc3

How reproducible:
Always

Steps to Reproduce:
1. open spadmin
2. redefine a CUPS printer as a oo.org fax device and add a command
3. exit and restart spadmin, the command is gone
  

Actual Results:  No command saved

Expected Results:  Command should have been saved

Additional info:
Comment 1 Brian Johnson 2005-06-10 11:54:41 EDT
why was this closed?
Comment 2 Brian Johnson 2005-06-20 09:58:21 EDT
No idea why this was closed.

Also, I've upgraded to FC4 and problem has changed but results are the same.

Now you cannot redefine a CUPS printer as a fax device at all.

Just to clarify, when using fax4cups it would be best if openoffice.org would
auto sense that printer as a fax device, but short of that it would be best to
be able to use spadmin to redefine it on each workstation.

Current situation is that fax2cups device shows in oo.org but is unusable.  A
second fax device must be added to use the fax4cups system which results in 2
printers showing up in oo.org.  One works, the other doesn't.  

Confusing, and it seems to be interpreted as an obvious bug, for users.

Comment 3 Brian Johnson 2005-06-22 09:29:08 EDT
Fax4cups homepage:
http://vigna.dsi.unimi.it/fax4CUPS

It is really easy to install and easily expands faxmodem sharing through your
network by using the CUPS autobrowsing features.

I reported it on openoffice.org here:
http://qa.openoffice.org/issues/show_bug.cgi?id=49920

They closed it because 1.1.x worked differently than 1.1.3 in FC3.  In their
version, the CUPS printers did not list in the spadmin program at all so
defining a CUPS printer as a fax device was possible by simply defining a oo.org
printer with the same name as a CUPS printer.  

Their solution was still not fully acceptable since although CUPS printers
displayed in the oo.org printer selection boxes (but not in spadmin), they did
not list the CUPS printer classes (groups of printers definable in CUPS) at all. 


I had to approach the problem from another angle to get them to consider doing
anything, so the above bug report evolved into this feature enhancement request
to Autosense fax4cups devices and configure automatically
http://qa.openoffice.org/issues/show_bug.cgi?id=49980

This bug report is related to this issue since it reinforces the current need to
use spadmin for setting up fax devices to "swallow" the fax number (ie not
include the fax number field in the fax output)
http://qa.openoffice.org/issues/show_bug.cgi?id=49981

Note You need to log in before you can comment on or make changes to this bug.