Bug 159161 - yum hangs on kernel update
yum hangs on kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-30 16:54 EDT by james
Modified: 2014-01-21 17:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 18:19:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2005-05-30 16:54:30 EDT
From Bugzilla Helper:
User-Agent: Opera/8.0 (X11; Linux i686; U; en)

Description of problem:
Attempting to update the kernel, yum hangs after "Running Transaction Test", with no disc activity and no cpu 
usage.

 $ sudo yum -y update kernel
 ...
 Resolving Dependencies
 --> Populating transaction set with selected packages. Please wait.
 ---> Package kernel.i586 0:2.6.11-1.27_FC3 set to be installed
 --> Running transaction check

 Dependencies Resolved
 Transaction Listing:
   Install: kernel.i586 0:2.6.11-1.27_FC3 - updates-released
 Total download size: 18 M
 Downloading Packages:
 Running Transaction Test
and hangs...

Also tried:
 $ sudo yum -y install kernel
with the same result.


Version-Release number of selected component (if applicable):
yum-2.2.1-0.fc3

How reproducible:
Always

Steps to Reproduce:
1.$ sudo yum -y update kernel
2.
3.
  

Actual Results:  yum hangs with no activity

Expected Results:  install kernel

Additional info:
Comment 1 Seth Vidal 2005-05-30 17:02:38 EDT
does the command 'df' hang?

how many kernels do you have installed?

If you strace the yum command what does it say it is doing?
Comment 2 james 2005-05-30 17:06:41 EDT
Hmm.  I just tried to run
 sudo rpm -ivh /var/cache/yum/updates-released/packages/kernel-2.6.11-1.27_FC3.i586.rpm
and that also hangs with no activity.  This is with rpm-4.3.2-21.

I suppose this is an rpm problem then, and not a yum problem.
Comment 3 Seth Vidal 2005-05-30 17:15:47 EDT
Answer the other questions I mentioned and we can see what might be causing it.

I think knowing what the strace output is and how many kernels you have
installed would help.

out of curiosity - is this really an i586 machine?
Comment 4 james 2005-05-30 17:28:46 EDT
> does the command 'df' hang?

Yes sir'ee Bob!  This seems to have something to do with an NFS mounted directory - flaky NFS at that.
I managed to unmount the remote directory and then rpm - and df - ran without problems.

Athlon machine, K7 I suppose - family 6, stepping 2.
Comment 5 Seth Vidal 2005-05-30 18:19:42 EDT
this is not a bug, closing.


Note You need to log in before you can comment on or make changes to this bug.