Bug 1591670 - Missing source path attribute for char device
Summary: Missing source path attribute for char device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1591674
TreeView+ depends on / blocked
 
Reported: 2018-06-15 09:12 UTC by Xiaodai Wang
Modified: 2019-08-06 13:08 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1591674 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:08:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
vit clone log (11.69 KB, text/plain)
2018-06-15 09:13 UTC, Xiaodai Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2232 0 None None None 2019-08-06 13:08:13 UTC

Description Xiaodai Wang 2018-06-15 09:12:53 UTC
Description of problem:
Missing source path attribute for char device

Version-Release number of selected component (if applicable):
virt-manager-1.5.0-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Prepare a guest with below unix channel.
  <channel type='unix'>
    <source mode='bind' path='/tmp/guestfwd'/>
    <target type='guestfwd' address='10.0.2.1' port='4600'/>
  </channel>
2. Clone the guest.
# virt-clone -o rhel7.5vnc --debug --auto-clone

Actual results:
[Fri, 15 Jun 2018 16:11:17 virt-clone 22262] DEBUG (cloner:459) Starting duplicate.
[Fri, 15 Jun 2018 16:11:17 virt-clone 22262] DEBUG (cloner:477) Duplicate failed: internal error: Missing source path attribute for char device
[Fri, 15 Jun 2018 16:11:17 virt-clone 22262] DEBUG (cli:317)   File "/usr/share/virt-manager/virt-clone", line 227, in <module>
    fail(main_e)
  File "/usr/share/virt-manager/virtinst/cli.py", line 317, in fail
    logging.debug("".join(traceback.format_stack()))

[Fri, 15 Jun 2018 16:11:17 virt-clone 22262] ERROR (cli:318) internal error: Missing source path attribute for char device
[Fri, 15 Jun 2018 16:11:17 virt-clone 22262] DEBUG (cli:320) 
Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-clone", line 221, in <module>
    sys.exit(main())
  File "/usr/share/virt-manager/virt-clone", line 212, in main
    design.start_duplicate(cli.get_meter())
  File "/usr/share/virt-manager/virtinst/cloner.py", line 469, in start_duplicate
    dom = self.conn.defineXML(self.clone_xml)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3676, in defineXML
    if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self)
libvirtError: internal error: Missing source path attribute for char device


Expected results:
The clone should success.

Additional info:
1) The difference of original and clone xml.
75,77c75,77
<     <channel type='unix'>
<       <source mode='bind' path='/tmp/guestfwd'/>
<       <target type='guestfwd' address='10.0.2.1' port='4600'/>
---
>     <channel type="unix">
>       <source mode="bind"/>
>       <target type="guestfwd" address="10.0.2.1" port="4600"/>

Comment 2 Xiaodai Wang 2018-06-15 09:13:38 UTC
Created attachment 1451832 [details]
vit clone log

Comment 3 Pavel Hrdina 2018-06-29 06:53:34 UTC
Upstream commit:

commit 931936a328d22413bb663e0e21d2f7bb111dbd7c
Author: Pavel Hrdina <phrdina>
Date:   Thu Jun 28 16:18:43 2018 +0200

    virtinst: Remove only auto-generated channel source path

Comment 5 zhoujunqin 2018-07-03 07:05:55 UTC
Hi,Pavel

Is this bug targeted for rhel7.6 since I see rhel-7.6.0+ flag is set, if so when will you plan to build the new virt-manager package including fix of this bug,thanks.

BR,
juzhou.

Comment 12 ysu@redhat.com 2019-04-30 07:01:50 UTC
I can reproduce this issue with package:
virt-manager-1.5.0-1.el7.noarch

Then try to verify this bug with new build:
virt-manager-1.5.0-3.el7.noarch
virt-install-1.5.0-3.el7.noarch
libvirt-4.5.0-12.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64
libvirt-python-4.5.0-1.el7.x86_64

Steps:


1. Prepare a guest with below unix channel.
  <channel type='unix'>
    <source mode='bind' path='/tmp/guestfwd'/>
    <target type='guestfwd' address='10.0.2.1' port='4600'/>
  </channel>
2. Clone the guest.
 #virt-clone -o rhel7.6 --debug --auto-clone

Allocating 'rhel7.6.qcow2'                        | 7.0 GB  03:57     
Clone 'rhel7.6-clone' created successfully.
3 Check unix channel of new guest in xml file.
 #virsh dumpxml rhel7.6-clone | grep channel

<channel type='unix'>
      <source mode='bind' path='/tmp/guestfwd'/>
      <target type='guestfwd' address='10.0.2.1' port='4600'/>
</channel>

Results:
 1.  The clone finishes with source path on xml file and new guest starts successfully.
 2.  The none auto-generated channel source path '/tmp/guestfwd' keeps during cloning.

 I move this bug from ON_QA to VERIFIED based on above testing.

Comment 13 ysu@redhat.com 2019-04-30 07:02:49 UTC
I can reproduce this issue with package:
virt-manager-1.5.0-1.el7.noarch

Then try to verify this bug with new build:
virt-manager-1.5.0-3.el7.noarch
virt-install-1.5.0-3.el7.noarch
libvirt-4.5.0-12.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64
libvirt-python-4.5.0-1.el7.x86_64

Steps:


1. Prepare a guest with below unix channel.
  <channel type='unix'>
    <source mode='bind' path='/tmp/guestfwd'/>
    <target type='guestfwd' address='10.0.2.1' port='4600'/>
  </channel>
2. Clone the guest.
 #virt-clone -o rhel7.6 --debug --auto-clone

Allocating 'rhel7.6.qcow2'                        | 7.0 GB  03:57     
Clone 'rhel7.6-clone' created successfully.
3 Check unix channel of new guest in xml file.
 #virsh dumpxml rhel7.6-clone | grep channel

<channel type='unix'>
      <source mode='bind' path='/tmp/guestfwd'/>
      <target type='guestfwd' address='10.0.2.1' port='4600'/>
</channel>

Results:
 1.  The clone finishes with source path on xml file and new guest starts successfully.
 2.  The none auto-generated channel source path '/tmp/guestfwd' keeps during cloning.

 I move this bug from ON_QA to VERIFIED based on above testing.

Comment 15 errata-xmlrpc 2019-08-06 13:08:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2232


Note You need to log in before you can comment on or make changes to this bug.