Bug 1592019 - SELinux is preventing /usr/libexec/sssd/sssd_be from map access on the file /usr/share/pki/ca-trust-source/ca-bundle.trust.p11-kit
Summary: SELinux is preventing /usr/libexec/sssd/sssd_be from map access on the file /...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1595773 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-16 09:03 UTC by Lukas Slebodnik
Modified: 2018-10-30 10:05 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-205.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:05:41 UTC

Description Lukas Slebodnik 2018-06-16 09:03:33 UTC
SELinux is preventing /usr/libexec/sssd/sssd_be from map access on the file /usr/share/pki/ca-trust-source/ca-bundle.trust.p11-kit.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sssd_be should be allowed map access on the ca-bundle.trust.p11-kit file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sssd_be' --raw | audit2allow -M my-sssdbe
# semodule -i my-sssdbe.pp


Additional Information:
Source Context                system_u:system_r:sssd_t:s0
Target Context                system_u:object_r:cert_t:s0
Target Objects                /usr/share/pki/ca-trust-source/ca-
                              bundle.trust.p11-kit [ file ]
Source                        sssd_be
Source Path                   /usr/libexec/sssd/sssd_be
Port                          <Unknown>
Host                          host.example.com
Source RPM Packages           sssd-common-1.16.2-1.el7.x86_64
Target RPM Packages           ca-certificates-2018.2.22-70.0.el7_5.noarch
Policy RPM                    selinux-policy-3.13.1-204.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     host.example.com
Platform                      Linux host.example.com
                              3.10.0-905.el7.x86_64 #1 SMP Wed Jun 13 13:48:50
                              EDT 2018 x86_64 x86_64
Alert Count                   11
First Seen                    2018-06-16 04:47:15 EDT
Last Seen                     2018-06-16 04:47:43 EDT
Local ID                      e9381aa7-1cc0-4137-b7e6-891a0f4e51e1

Raw Audit Messages
type=AVC msg=audit(1529138863.108:646): avc:  denied  { map } for  pid=23371 comm="sssd_be" path="/usr/share/pki/ca-trust-source/ca-bundle.trust.p11-kit" dev="dm-0" ino=33572827 scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:object_r:cert_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1529138863.108:646): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=ea0c4 a2=1 a3=2 items=0 ppid=23370 pid=23371 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sssd_be exe=/usr/libexec/sssd/sssd_be subj=system_u:system_r:sssd_t:s0 key=(null)

Hash: sssd_be,sssd_t,cert_t,file,map

Comment 2 Lukas Slebodnik 2018-06-16 09:04:56 UTC
it seems to be related to BZ1592016. So I assume it happens in openldap librearies

Comment 4 Sumit Bose 2018-06-27 14:47:41 UTC
*** Bug 1595773 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2018-10-30 10:05:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.