Bug 1592022 - SELinux is preventing /usr/libexec/oddjob/mkhomedir from map access on the file /usr/libexec/oddjob/mkhomedir
Summary: SELinux is preventing /usr/libexec/oddjob/mkhomedir from map access on the fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1595768 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-16 09:23 UTC by Lukas Slebodnik
Modified: 2018-10-30 10:05 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-205.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:05:41 UTC

Description Lukas Slebodnik 2018-06-16 09:23:52 UTC
SELinux is preventing /usr/libexec/oddjob/mkhomedir from map access on the file /usr/libexec/oddjob/mkhomedir.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that mkhomedir should be allowed map access on the mkhomedir file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'mkhomedir' --raw | audit2allow -M my-mkhomedir
# semodule -i my-mkhomedir.pp


Additional Information:
Source Context                system_u:system_r:oddjob_t:s0-s0:c0.c1023
Target Context                system_u:object_r:oddjob_mkhomedir_exec_t:s0
Target Objects                /usr/libexec/oddjob/mkhomedir [ file ]
Source                        mkhomedir
Source Path                   /usr/libexec/oddjob/mkhomedir
Port                          <Unknown>
Host                          hp-dl320egen8-0.sssdad.com
Source RPM Packages           oddjob-mkhomedir-0.31.5-4.el7.x86_64
Target RPM Packages           oddjob-mkhomedir-0.31.5-4.el7.x86_64
Policy RPM                    selinux-policy-3.13.1-204.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     hp-dl320egen8-0.sssdad.com
Platform                      Linux hp-dl320egen8-0.sssdad.com
                              3.10.0-905.el7.x86_64 #1 SMP Wed Jun 13 13:48:50
                              EDT 2018 x86_64 x86_64
Alert Count                   23
First Seen                    2018-06-16 05:01:33 EDT
Last Seen                     2018-06-16 05:08:38 EDT
Local ID                      ced71209-7449-4713-8231-265d4a741f94

Raw Audit Messages
type=AVC msg=audit(1529140118.350:794): avc:  denied  { map } for  pid=32159 comm="mkhomedir" path="/usr/libexec/oddjob/mkhomedir" dev="dm-0" ino=1004143 scontext=system_u:system_r:oddjob_t:s0-s0:c0.c1023 tcontext=system_u:object_r:oddjob_mkhomedir_exec_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1529140118.350:794): arch=x86_64 syscall=execve success=no exit=EACCES a0=55a962a500a0 a1=55a962a51b40 a2=55a962a51bf0 a3=686b6d5f626f6a64 items=0 ppid=26445 pid=32159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=mkhomedir exe=/usr/libexec/oddjob/mkhomedir subj=system_u:system_r:oddjob_t:s0-s0:c0.c1023 key=(null)

Hash: mkhomedir,oddjob_t,oddjob_mkhomedir_exec_t,file,map

Comment 3 Sumit Bose 2018-06-27 14:44:09 UTC
*** Bug 1595768 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2018-10-30 10:05:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.