Bug 1592032 - SELinux is preventing /usr/sbin/ypserv from map access on the file /var/yp/ipatest/group.byname
Summary: SELinux is preventing /usr/sbin/ypserv from map access on the file /var/yp/ip...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1595121 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-16 10:36 UTC by Lukas Slebodnik
Modified: 2018-10-30 10:06 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-205.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:06:45 UTC

Description Lukas Slebodnik 2018-06-16 10:36:02 UTC
SELinux is preventing /usr/sbin/ypserv from map access on the file /var/yp/ipatest/group.byname.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ypserv should be allowed map access on the group.byname file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ypserv' --raw | audit2allow -M my-ypserv
# semodule -i my-ypserv.pp


Additional Information:
Source Context                system_u:system_r:ypserv_t:s0
Target Context                system_u:object_r:var_yp_t:s0
Target Objects                /var/yp/ipatest/group.byname [ file ]
Source                        ypserv
Source Path                   /usr/sbin/ypserv
Port                          <Unknown>
Host                          host.example.com
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-204.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     host.example.com
Platform                      Linux host.example.com
                              3.10.0-905.el7.x86_64 #1 SMP Wed Jun 13 13:48:50
                              EDT 2018 x86_64 x86_64
Alert Count                   69
First Seen                    2018-06-16 05:07:30 EDT
Last Seen                     2018-06-16 06:29:30 EDT
Local ID                      99531e47-fb49-4087-abda-523f28e74087

Raw Audit Messages
type=AVC msg=audit(1529144970.975:456): avc:  denied  { map } for  pid=28968 comm="ypserv" path="/var/yp/ipatest/group.byname" dev="dm-0" ino=67894073 scontext=system_u:system_r:ypserv_t:s0 tcontext=system_u:object_r:var_yp_t:s0 tclass=file permissive=0


Hash: ypserv,ypserv_t,var_yp_t,file,map

Comment 2 Lukas Vrabec 2018-06-26 08:42:26 UTC
*** Bug 1595121 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2018-10-30 10:05:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.