Bug 1592067 - windows crash while testing F28 kernel 4.17
Summary: windows crash while testing F28 kernel 4.17
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-amdgpu
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Christopher Atherton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-16 16:41 UTC by Brad Walker
Modified: 2019-05-28 21:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 21:50:14 UTC
Type: Bug


Attachments (Terms of Use)
dmesg output showing the drm error (3.92 KB, text/plain)
2018-06-16 16:41 UTC, Brad Walker
no flags Details

Description Brad Walker 2018-06-16 16:41:42 UTC
Created attachment 1452208 [details]
dmesg output showing the drm error

Description of problem:

I am testing Fedora 28 running the Linux 4.17 kernel.
https://fedoraproject.org/wiki/Test_Day:2018-06-12_Kernel_4.17_Test_Day

My window system crashes with the following error.

 [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3
 [drm:hwss_wait_for_blank_complete [amdgpu]] *ERROR* DC: failed to blank crtc!
[  

The system is an HP 17-g121wm with a A10-8700P processor. This system contains an AMD Radeon R6 gpu

Version-Release number of selected component (if applicable):

F28 w/ Linux kernel 4.17


How reproducible:

Boot the F28 test day image on an machine w/ A10-8700P processor.


Expected results:

No window system crashes.

Comment 1 Hin-Tak Leung 2018-06-28 20:42:20 UTC
This seems to be a regression. I only started to see 
[drm:hwss_wait_for_blank_complete [amdgpu]] *ERROR* DC: failed to blank crtc!

with kernel 4.17.2-200.fc28.x86_64 . And also problems with suspend/resume .
(system not going to sleep, or not coming out of it).

previous kernel,
4.16.16-300.fc28.x86_64,
4.16.15-300.fc28.x86_64
4.16.14-300.fc28.x86_64,
4.16.13-300.fc28.x86_64,
4.16.11-300.fc28.x86_64,

don't have this problem.

Comment 2 Hin-Tak Leung 2018-06-28 20:43:01 UTC
That was information from looking at /var/log/messages* back for the last month.

Comment 3 Hin-Tak Leung 2018-06-28 20:45:49 UTC
My CPU from /proc/cpuinfo

model name	: AMD A9-9410 RADEON R5, 5 COMPUTE CORES 2C+3G

Comment 4 Gabriel C 2018-06-29 00:48:17 UTC
As workaround try to boot with amdgpu.dc=0

Comment 5 Brad Walker 2018-07-09 01:48:25 UTC
I did boot with the following setting "amdgpu.dc=0" and still get the problem.

I'm willing to test any debug modules one may have to help get this solved.

Comment 6 Hin-Tak Leung 2018-07-11 17:25:43 UTC
I was able to suspend and resume with amdgpu.dc=0 and 4.17.3-200.fc28.x86_64 for a few days between Jul 6 and Jul 10 for about 6 times but failed three times sincce, same combination. Don't know what's the difference.

It seems that it has problem waking, I think. The screen remains blank.

Comment 7 Ben Cotton 2019-05-02 21:19:42 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Ben Cotton 2019-05-28 21:50:14 UTC
Fedora 28 changed to end-of-life (EOL) status on 2019-05-28. Fedora 28 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.