Bug 1592142 - Firefox on Wayland cut/copy/paste issue
Summary: Firefox on Wayland cut/copy/paste issue
Keywords:
Status: CLOSED DUPLICATE of bug 1585393
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2018-06-17 19:28 UTC by Dan Loomis
Modified: 2018-06-25 02:53 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-25 02:53:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Dan Loomis 2018-06-17 19:28:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:  Easy


Steps to Reproduce:
1.  Run Firefox on Wayland, 
2.  Open Incognito Window.
3   Open some tabs and visit some sites.
4.  Copy some text to the clipboard
5.  Switch tabs in Firefox

Intermediate test to confirm copy worked:
Steps to Reproduce:
1.  Run Firefox on Wayland
2.  Copy something to the clipboard
3.  Paste into search field (This step confirms content on the clipboard.)
4.  Launch gedit
5   Paste

Steps to Reproduce:
1.  Run Firefox on Wayland, 
2.  Open Incognito Window.
3   Open some tabs and visit some sites in both windows.
4.  Copy some text to the clipboard
5.  Switch to tab in incognito window (Clipboard will now be empty)

Actual results:
Clipboard is often empty.

Expected results:
Content user placed on clipboard should remain there until the user changes it.

Additional info:
I originally thought this was restricted to Incognito mode, but discovered just now when creating this bug report that regular mode can be challenged by cut/copy/paste.  Something is clearing the clipboard after the cut/copy.

Comment 1 Elliott Sales de Andrade 2018-06-25 02:53:55 UTC

*** This bug has been marked as a duplicate of bug 1585393 ***


Note You need to log in before you can comment on or make changes to this bug.