Bug 159216 - vixie-cron updates for new audit system
vixie-cron updates for new audit system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vixie-cron (Show other bugs)
4.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
: FutureFeature
Depends On:
Blocks: 113381 156322
  Show dependency treegraph
 
Reported: 2005-05-31 13:33 EDT by Steve Grubb
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHSA-2005-361
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 08:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2005-05-31 13:33:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The vixie-cron package needs some updates for the eal4 certification.

1) The following needs to be added to its pam configuration:

session    required     pam_loginuid.so

It will need to change the Requires to state the pam version that includes the pam_loginuid patch.

2) There were a number of pam cleanups that went into FC4 regarding session closure. They are also required for eal4 cert. They may already be in cvs, I just need to make sure they are in RHEL4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. New functionality

Additional info:

* The pam config change can be done for rawhide. I think pam-0.79-6 and later have the loginuid module.
Comment 1 Jason Vas Dias 2005-05-31 16:10:15 EDT
I'll update the /etc/pam.d/crond file to require 
'session required pam_loginuid.so'
when pam_loginuid is in RHEL-4 , and in rawhide
on next cron update.
Comment 2 Jason Vas Dias 2005-05-31 16:11:36 EDT
I'll update the /etc/pam.d/atd file to require 
'session required pam_loginuid.so'
when pam_loginuid is in RHEL-4 , and in rawhide
on next at update.
Comment 5 Jason Vas Dias 2005-06-17 13:29:35 EDT
vixie-cron-4.1-EL4.34 now submitted to RHEL-4 with requisite 
/etc/pam.d/crond file using pam_loginuid.so .
Comment 9 Red Hat Bugzilla 2005-10-05 08:34:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2005-361.html

Note You need to log in before you can comment on or make changes to this bug.