Bug 15922 - Problems with bind and caching-nameserver
Problems with bind and caching-nameserver
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 10:25 EDT by John William
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 10:26:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2000-08-10 10:25:23 EDT
I have RH 6.2 installed on a dual processor pentium machine. I have the 
packages bind-8.2.2_P5-9 and caching-nameserver-6.2-2 installed to make 
the machine act as a caching-only nameserver for a small workgroup. I have 
used the firewalld daemon in Linuxconf 1.19r2 to set up a simple firewall. 
Linuxconf has correctly set up the ethernet adapters for the local network 
and the internet interface. I am using the 2.2.16 kernel.

I have had this problem happen several times. After an extended uptime, 
named is unable to resolve some hostnames from external machines, but can 
resolve the same hostnames locally.

For example, when I run "nslookup pop-server.wi.rr.com" I get:

Server:  mkesms2.wi.rr.com
Address:  24.160.227.33

Name:    pop-server.wi.rr.com
Addresses:  24.94.163.171, 24.94.163.172

When I run "ping pop-server.wi.rr.com" from one of the clients on the 
local network, I get:

C:\WINDOWS>ping pop-server.wi.rr.com
Unknown host pop-server.wi.rr.com.

The only indication there is a problem is in /var/log/messages when I try 
a lookup from a remote machine:

Aug 10 09:22:15 copper-dragon named[21168]: ns_forw: query(pop-
server.wi.rr.com)
 NS points to CNAME (ns1.wi.rr.com:)
Aug 10 09:22:15 copper-dragon named[21168]: ns_forw: query(pop-
server.wi.rr.com)
 No possible A RRs

I do not get these messages when I perform the lookup locally.
Comment 1 Bernhard Rosenkraenzer 2000-08-14 10:52:38 EDT
Can't reproduce this...
If it's only after a prolonged uptime, maybe running "ndc reload" every couple
of days from cron helps you?
Comment 2 John William 2000-08-14 21:31:28 EDT
I'm sorry you couldn't reproduce it, but I am not the only person having this 
problem so I know it isn't just me. I have verified everything is installed 
correctly with "rpm -V" on the bind and caching-nameserver packages so nothing 
has modified the out-of-the-box settings. The problem seems to take 3-5 days on 
my test server before cropping up, but it is easily reproducable here.

Reloading/restarting named doesn't work. Once named gets into a "mood" the 
process has to be killed to restore normal operation. And once the problem 
starts, it seems to quickly spread to affect all lookups from any machine 
except the host. On the host everything works fine.

Note You need to log in before you can comment on or make changes to this bug.