Bug 1592217 - When joining two projects if the first project does not exist, the error message is inaccurate
Summary: When joining two projects if the first project does not exist, the error mess...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: jtanenba
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-18 08:24 UTC by Birol Bilgin
Modified: 2019-08-08 02:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC
Origin (Github) 22479 None None None 2019-04-04 15:15:34 UTC

Description Birol Bilgin 2018-06-18 08:24:09 UTC
Description of problem:

When joining two projects with the command "oc adm pod-network join-projects", if the first project does not exist, the error message is inaccurate.

"error: Project "pc" failed to join "pa", error: timed out waiting for the condition"


Version-Release number of selected component (if applicable):
oc v3.7.42
kubernetes v1.7.6+a08f5eeb62


How reproducible:
Allways

Steps to Reproduce:
1. oc new project pa
2. oc new-project pb
3. oc adm pod-network join-projects --to=pc pa
error: Project "pa" failed to join "pc", error: timed out waiting for the condition
4. oc adm pod-network join-projects --to=pa pc
error: No projects found

Actual results:
error: Project "pa" failed to join "pc", error: timed out waiting for the condition

Expected results:
error: No projects found

Comment 2 Ben Bennett 2019-04-05 15:55:25 UTC
Fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1592217

Comment 4 zhaozhanqi 2019-04-15 05:10:55 UTC
Verified this bug on 
$ oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"eee567b9d", GitTreeState:"", BuildDate:"2019-04-14T17:00:04Z", GoVersion:"", Compiler:"", Platform:""}

$ oc adm pod-network join-projects --to=pc pa
error: no projects found

Comment 6 errata-xmlrpc 2019-06-04 10:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.