Bug 1592355 - [freeipa] Drop requirements for 'initscripts' from specfile
Summary: [freeipa] Drop requirements for 'initscripts' from specfile
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1592330
TreeView+ depends on / blocked
 
Reported: 2018-06-18 13:07 UTC by David Kaspar [Dee'Kej]
Modified: 2018-06-19 19:11 UTC (History)
9 users (show)

Fixed In Version: freeipa-4.6.90.pre2-7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-19 19:11:26 UTC
Type: Bug


Attachments (Terms of Use)

Description David Kaspar [Dee'Kej] 2018-06-18 13:07:56 UTC
Hello!

Description of problem:
It appears your package depend on 'initscrits' package for some reason. However, most of the initscripts' dependants are no longer valid.

I hereby request you check your package/specfile, and either:
 * drop the initscripts dependancy and close this BZ, or
 * provide a justification in a comment for keeping the dependancy (without closing this BZ)

----------------------

NOTE: In case you are depending on initscripts because of networking scripts, then you will need to update your specfile to depend directly on new package 'network-scripts' (instead of 'initscripts').

If this is the case, please let us know in the comments and do not close the BZ  yet.

Additional info:
The requested change here is valid for Rawhide (F29) only. Do not backport these changes into F28 or F27, because it would break things.

Thank you for your co-operation! :)

 -- Dee'Kej --

Comment 1 Florence Blanc-Renaud 2018-06-18 16:43:29 UTC
Bug analysis
------------
Valid bug: yes
Regression: no
Regression introduction: N/A
Affected versions: Fedora 29
Cause: dependency on 'initscripts' package should be replaced by dependency on 'hostname' package
Workaround: None
Fix complexity: easy


This dependency was added because we need /usr/lib/systemd/system/*-domainname.service file (see commit https://pagure.io/freeipa/c/771dea5c6bf1cca7b3756d2f1be48f613de14ceb).

On fedora <=28, the actual file is /usr/lib/systemd/system/fedora-domainname.service and is provided by initscripts package:

# cat /etc/redhat-release
Fedora release 28 (Twenty Eight)
# dnf provides /usr/lib/systemd/system/fedora-domainname.service
Last metadata expiration check: 0:50:49 ago on Mon 18 Jun 2018 05:48:12 PM CEST.
initscripts-9.80-1.fc28.x86_64 : Scripts to bring up network interfaces and
                               : legacy utilities
Repo        : @System
Matched from:
Filename    : /usr/lib/systemd/system/fedora-domainname.service

initscripts-9.80-1.fc28.x86_64 : Scripts to bring up network interfaces and
                               : legacy utilities
Repo        : updates
Matched from:
Filename    : /usr/lib/systemd/system/fedora-domainname.service

initscripts-9.79-3.fc28.x86_64 : Scripts to bring up network interfaces and
                               : legacy utilities
Repo        : fedora
Matched from:
Filename    : /usr/lib/systemd/system/fedora-domainname.service

On fedora 29, the actual file is /usr/lib/systemd/system/nis-domainname.service and is provided by hostname package.

# cat /etc/redhat-release 
Fedora release 29 (Rawhide)
[root@vm-194 ~]# dnf provides /usr/lib/systemd/system/nis-domainname.service
Last metadata expiration check: 0:19:54 ago on Mon 18 Jun 2018 06:20:02 PM CEST.
hostname-3.20-5.fc29.x86_64 : Utility to set/show the host name or domain name
Repo        : @System
Matched from:
Filename    : /usr/lib/systemd/system/nis-domainname.service

hostname-3.20-5.fc29.x86_64 : Utility to set/show the host name or domain name
Repo        : rawhide
Matched from:
Filename    : /usr/lib/systemd/system/nis-domainname.service

Comment 2 Florence Blanc-Renaud 2018-06-19 12:36:48 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7591

Comment 3 Christian Heimes 2018-06-19 16:07:39 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/0b794cd43b0e8a18517cbccdec2f183ce4cb38ec


Note You need to log in before you can comment on or make changes to this bug.