Bug 1592427 - [UPDATE][SCALE-UP] After update and scale up all origin node are in ERROR status
Summary: [UPDATE][SCALE-UP] After update and scale up all origin node are in ERROR status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 13.0 (Queens)
Assignee: Sofer Athlan-Guyot
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
: 1592466 (view as bug list)
Depends On: 1590297 1592466
Blocks: 1592432
TreeView+ depends on / blocked
 
Reported: 2018-06-18 13:59 UTC by Matthew Booth
Modified: 2019-09-09 14:23 UTC (History)
27 users (show)

Fixed In Version: instack-undercloud-8.4.1-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1590297
Environment:
Last Closed: 2018-06-27 13:58:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 576165 None None None 2018-06-21 08:43:47 UTC
OpenStack gerrit 576165 None MERGED Make sure we start nova-compute after ironic-conductor. 2020-04-15 08:10:54 UTC
OpenStack gerrit 576909 None MERGED Make sure we start nova-compute after ironic-conductor. 2020-04-15 08:10:54 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:59:06 UTC

Comment 2 Matthew Booth 2018-06-18 14:04:23 UTC
I think we can robustify nova here by not calling plug_vifs unnecessarily for a driver which doesn't require it. The driver interface already has resume_state_on_host_boot(), which ironic doesn't implement. The requirement to plug vifs on host boot does seem very driver-specific, so having drivers which require it call plug_vifs() explicitly doesn't seem terrible. I suspect that other 'external' hypervisors probably also wouldn't bother, like PowerVM and VMware.

It looks like we need to work out the interaction with the code to fixup interrupted migrations.

Comment 3 Sofer Athlan-Guyot 2018-06-19 08:35:21 UTC
Adding an upstream tracker in order to be able to add comment in the instack-undercloud workaround that says "removed when lp1777606 is fixed instead of embedding bz id in there.

Comment 4 Carlos Camacho 2018-06-21 08:38:36 UTC
It was mistakenly updated the nova fix in the instack-undercloud BZ, as the fix was merged/backported and the build created, we are switching BZs.

Comment 7 Matthew Booth 2018-06-21 10:21:01 UTC
*** Bug 1592466 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2018-06-27 13:58:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.