Bug 159244 - Failed mounting music player as usbdisk
Failed mounting music player as usbdisk
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-31 16:32 EDT by Dov Grobgeld
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-14 11:36:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2005-05-31 16:32:03 EDT
Description of problem:

When connecting my iRiver device to the USB disk I get the following messages in
/var/log/messages:

May 31 23:22:28 grower kernel: usb 3-2: new full speed USB device using ohci_hcd
and address 2
May 31 23:22:28 grower kernel: scsi3 : SCSI emulation for USB Mass Storage devices
May 31 23:22:57 grower kernel: usb 3-2: reset full speed USB device using
ohci_hcd and address 2
May 31 23:22:57 grower kernel: usb 3-2: device not accepting address 2, error -32
May 31 23:22:57 grower kernel: usb 3-2: reset full speed USB device using
ohci_hcd and address 2
May 31 23:22:58 grower kernel: usb 3-2: device not accepting address 2, error -32
May 31 23:22:58 grower kernel: usb 3-2: reset full speed USB device using
ohci_hcd and address 2
May 31 23:22:58 grower kernel: usb 3-2: device not accepting address 2, error -32
May 31 23:22:58 grower kernel: usb 3-2: reset full speed USB device using
ohci_hcd and address 2
May 31 23:22:59 grower kernel: usb 3-2: device not accepting address 2, error -32
May 31 23:22:59 grower kernel: scsi: Device offlined - not ready after error
recovery: host 3 channel 0 id 0 lun 0
May 31 23:22:59 grower kernel: usb 3-2: USB disconnect, address 2
May 31 23:22:59 grower kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000060
May 31 23:22:59 grower kernel:  printing eip:
May 31 23:22:59 grower kernel: c01cdcf8
May 31 23:22:59 grower kernel: *pde = 16d30067
May 31 23:22:59 grower kernel: Oops: 0000 [#1]
May 31 23:22:59 grower kernel: Modules linked in: parport_pc lp parport autofs4
i2c_dev i2c_core sunrpc vfat fat dm_mod video button battery ac usb_storage
usblp md5 ipv6 joydev ohci_hcd ehci_hcd snd_intel8x0 snd_ac97_codec
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc sis900 floppy ext3
jbd sata_sis libata sd_mod scsi_mod
May 31 23:22:59 grower kernel: CPU:    0
May 31 23:22:59 grower kernel: EIP:    0060:[<c01cdcf8>]    Not tainted VLI
May 31 23:22:59 grower kernel: EFLAGS: 00010296   (2.6.11-1.1366_FC4) 
May 31 23:22:59 grower kernel: EIP is at sysfs_hash_and_remove+0xe/0xf1
May 31 23:22:59 grower kernel: eax: 00000000   ebx: d63eb664   ecx: 00000000  
edx: c039215c
May 31 23:22:59 grower kernel: esi: d63eb65c   edi: e0883830   ebp: e08837a0  
esp: c171edd8
May 31 23:22:59 grower kernel: ds: 007b   es: 007b   ss: 0068
May 31 23:22:59 grower kernel: Process khubd (pid: 86, threadinfo=c171e000
task=c170a000)
May 31 23:22:59 grower kernel: Stack: c039215c 00000000 c03c9ab8 d63eb664
d63eb65c e0883830 e08837a0 c0288f4d 
May 31 23:22:59 grower kernel:        e0883838 d63eb65c d63eb400 d63eb858
00000202 c0288f89 d63eb800 e086c954 
May 31 23:22:59 grower kernel:        d63eb7f8 d63eb800 db707880 e086ca6a
00000003 d4f42d4c c019f823 00000002 
May 31 23:22:59 grower kernel: Call Trace:
May 31 23:22:59 grower kernel:  [<c0288f4d>] class_device_del+0x93/0xc7
May 31 23:22:59 grower kernel:  [<c0288f89>] class_device_unregister+0x8/0x10
May 31 23:22:59 grower kernel:  [<e086c954>] scsi_remove_device+0x49/0x8c [scsi_mod]
May 31 23:22:59 grower kernel:  [<e086ca6a>] __scsi_remove_target+0xd3/0x333
[scsi_mod]
May 31 23:22:59 grower kernel:  [<c019f823>] generic_delete_inode+0x142/0x346
May 31 23:22:59 grower kernel:  [<e086ccd5>] scsi_remove_target+0xb/0x5a [scsi_mod]
May 31 23:22:59 grower kernel:  [<e086b9e3>] scsi_forget_host+0x91/0x2e9 [scsi_mod]
May 31 23:22:59 grower kernel:  [<e0862056>] scsi_remove_host+0x9/0x4b [scsi_mod]
May 31 23:22:59 grower kernel:  [<e09aaf86>] storage_disconnect+0x5f/0x79
[usb_storage]
May 31 23:22:59 grower kernel:  [<c02cbcd2>] usb_unbind_interface+0x34/0x5d
May 31 23:22:59 grower kernel:  [<c0287e89>] device_release_driver+0x45/0x50
May 31 23:22:59 grower kernel:  [<c028808f>] bus_remove_device+0x65/0x9e
May 31 23:22:59 grower kernel:  [<c02872e3>] device_del+0x65/0x92
May 31 23:22:59 grower kernel:  [<c02d557e>] usb_disable_device+0x97/0xe4
May 31 23:22:59 grower kernel:  [<c02ce5d1>] usb_disconnect+0xa5/0x296
May 31 23:22:59 grower kernel:  [<c02cf5f4>] hub_port_connect_change+0x51/0x626
May 31 23:22:59 grower kernel:  [<c02cfec0>] hub_events+0x2f7/0x577
May 31 23:22:59 grower kernel:  [<c02d018d>] hub_thread+0x4d/0x10a
May 31 23:22:59 grower kernel:  [<c0140052>] autoremove_wake_function+0x0/0x37
May 31 23:22:59 grower kernel:  [<c02d0140>] hub_thread+0x0/0x10a
May 31 23:22:59 grower kernel:  [<c01012ad>] kernel_thread_helper+0x5/0xb
May 31 23:22:59 grower kernel: Code: 0c c7 44 24 08 8d 00 00 00 c7 44 24 04 84
ae 38 c0 c7 04 24 d0 1a 38 c0 e8 d9 2b f5 ff 55 57 56 53 83 ec 0c 89 44 24 04 89
14 24 <8b> 70 60 8b 58 20 ba 66 00 00 00 b8 eb 51 38 c0 e8 ae f8 f4 ff 

Version-Release number of selected component (if applicable):

uname -a yields:

    Linux grower.grobnet 2.6.11-1.1366_FC4 #1 Sun May 29 23:58:27 EDT 2005 i686
i686 i386 GNU/Linux

How reproducible:

Every time.

Steps to Reproduce:
1. Connect iRiver to USB
2.
3.
  
Actual results:

See above.

Expected results:

I expected the device to appear in /media/usbdisk , which is what happened in
Fedora Core 3.

Additional info:

Please let me know if you need more.
Comment 1 Pete Zaitcev 2005-06-11 00:15:59 EDT
Dov, can you tell me what kernel was that worked last (I presume, on FC3)?
Comment 2 Dov Grobgeld 2005-06-13 17:55:51 EDT
In this case I have to admit that in my stupidity I did not save the FC3
partition when I upgraded. Thus the only information that I can give is that I
kept doing "yum update" while I was using FC3 and it never broke. Perhaps there
are some log files that can help, but you would have to tell me which.

If it helps I can try mounting the device on my older PIII 800MBox which I also
upgraded to FC4, and then find out whether the problem is with the device, or
the USB controller?
Comment 3 Pete Zaitcev 2005-06-13 18:16:58 EDT
Yes, please do it with the PIII. While it looks like a regression when FC3
worked and FC4 fails on the same hardware, trying various combinations
of hardware gives useful hints. There's too much difference between FC3
and FC4 kernels for me to guess outright from the .diff.
Comment 4 Dov Grobgeld 2005-06-14 11:36:30 EDT
I'm ashamed to admit this, but when I now tried to mount the device again with a
fully charged battery, it mounted flawlessly. I really should have checked this
before. My apologies. But I am happy that it works. Closing the bug.
Comment 5 Pete Zaitcev 2005-06-14 12:12:08 EDT
I'm glad the workaround exists, but the kernel must not oops. That's
what the bug is. I'll pass this over to the upstream for now.
Comment 6 Dov Grobgeld 2005-06-29 12:35:15 EDT
Tried this on the latest kernel:

   Linux grower.grobnet 2.6.12-1.1400_FC5 #1 Thu Jun 23 23:19:41 EDT 2005 i686
i686 i386 GNU/Linux

and the device mounts ok, even with a half-empty battery. :-)

Note You need to log in before you can comment on or make changes to this bug.