Bug 1592509 - ctime: Self heal of symlink is failing on EC subvolume
Summary: ctime: Self heal of symlink is failing on EC subvolume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1593536
TreeView+ depends on / blocked
 
Reported: 2018-06-18 17:39 UTC by Kotresh HR
Modified: 2018-10-23 15:11 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1593536 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:11:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-06-18 17:39:07 UTC
Description of problem:
With ctime feature enabled, self heal of symlink is failing

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. The testcase ./tests/bugs/heal-symlinks.t always fails


Actual results:
Self heal of symlink fails in EC volume

Expected results:
Self heal of symlink should not fail in EC volume

Additional info:

Comment 1 Worker Ant 2018-06-18 17:50:45 UTC
REVIEW: https://review.gluster.org/20311 (ctime: Fix self heal of symlink in EC volume) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-06-20 06:52:09 UTC
COMMIT: https://review.gluster.org/20311 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- ctime: Fix self heal of symlink in EC volume

Since IEEE Std 1003.1-2001 does not require any
association of file times with symbolic links,
there is no requirement that file times be
updated by readlink() states [1].

stat on symlink file was generating a readlink
fop on one of the subvolumes of ec set which
in turn updates atime on that subvolume. This
causes mdata xattr to be different across ec
set and hence self heal fails. So based on [1],
atime is no longer updated by readlink fop.

[1] http://pubs.opengroup.org/onlinepubs/009695399/functions/readlink.html

fixes: bz#1592509
Change-Id: I08bd3ca3bdb222bd18160b1aa58fc2f7630c8083
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:11:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.