Bug 1592648 - Create pseries-rhel7.6.0-sxxm machine type
Summary: Create pseries-rhel7.6.0-sxxm machine type
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: ppc64le
OS: Linux
urgent
high
Target Milestone: rc
: 7.6
Assignee: David Gibson
QA Contact: Qunfang Zhang
URL:
Whiteboard:
Depends On:
Blocks: 1595501 1651449 1651480
TreeView+ depends on / blocked
 
Reported: 2018-06-19 04:29 UTC by David Gibson
Modified: 2019-04-02 13:22 UTC (History)
11 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1595501 (view as bug list)
Environment:
Last Closed: 2018-11-01 11:10:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1579738 None None None 2019-11-06 15:21:31 UTC
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:12:30 UTC

Internal Links: 1579738

Description David Gibson 2018-06-19 04:29:26 UTC
Description of problem:

To make things easier for management layers, we currently provide a number of variants of the pseries-rhel machine types which enable by default the Spectre & Meltdown mitigations.  Specifically we have:
    pseries-rhel7.3.0-sxxm
    pseries-rhel7.4.0-sxxm
    pseries-rhel7.5.0-sxxm

We don't currently have an equivalent variant for rhel 7.6.0.  This is because we had been hoping that in the rhel 7.6.0 timeframe we might be able to enable the mitigations by default and dispense with the extra machine type.

Enabling the mitigations also requires updated firmware, and at this stage it's looking like that firmware (at least for POWER8) still won't be widely deployed at 7.6 release.

Therefore we probably need to keep the mitigations off by default and provide the -sxxm machine type variant to turn them on.

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.12.0-3.el7

How reproducible:

100%

Steps to Reproduce:
1. Run 'qemu-kvm -machine ?'

Actual results:

'pseries-rhel7.5.0-sxxm' is listed, but 'pseries-rhel7.6.0-sxxm' is not.

Expected results:

'pseries-rhel7.6.0-sxxm' variant is listed amongst others.

Additional info:

Still need to confirm with IBM and PM if we want this.

Comment 2 David Gibson 2018-06-19 04:31:14 UTC
Andrew Bolognani suggests consistency across RHEL7 as another argument for including the pseries-rhel7.6.0-sxxm variant, with the intention being to revisit enabling the mitigations by default in RHEL 8.0.

Comment 3 David Gibson 2018-06-25 04:12:01 UTC
Updated POWER8 firmware which allows the mitigations was released on 22 May 2018 (FW860.51).  It's not terribly clear how widely deployed it is yet.

Comment 5 David Gibson 2018-06-26 04:12:31 UTC
We'll obviously need this new machine type for RHEL8 and qemu-kvm-ma as well.

Mirek, do we need to clone the bug for those, or do we have the same source base for the time being?

Comment 6 Miroslav Rezanina 2018-06-26 04:26:44 UTC
We do not need clone for qemu-kvm-ma (7.60) but we need clone for RHEL 8.

Comment 7 Miroslav Rezanina 2018-07-24 14:29:20 UTC
Fix included in qemu-kvm-rhev-2.12.0-8.el7

Comment 9 Qunfang Zhang 2018-08-07 09:30:29 UTC
# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-2.12.0-9.el7.ppc64le

# /usr/libexec/qemu-kvm -M help
Supported machines are:
none                 empty machine
pseries-rhel7.2.0    pSeries Logical Partition (PAPR compliant)
pseries-rhel7.3.0    pSeries Logical Partition (PAPR compliant)
pseries-rhel7.3.0-sxxm pSeries Logical Partition (PAPR compliant)
pseries-rhel7.4.0    pSeries Logical Partition (PAPR compliant)
pseries-rhel7.4.0-sxxm pSeries Logical Partition (PAPR compliant)
pseries-rhel7.5.0    pSeries Logical Partition (PAPR compliant)
pseries-rhel7.5.0-sxxm pSeries Logical Partition (PAPR compliant)
pseries              pSeries Logical Partition (PAPR compliant) (alias of pseries-rhel7.6.0)
pseries-rhel7.6.0    pSeries Logical Partition (PAPR compliant) (default)
pseries-rhel7.6.0-sxxm pSeries Logical Partition (PAPR compliant)

Run a round of kvm acceptance test with above qemu-kvm-rhev version with pseries-rhel7.6.0-sxxm, result is PASS.

Comment 12 errata-xmlrpc 2018-11-01 11:10:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.