Bug 1593080 - Non-fatal POSTIN scriptlet failure in rpm package 1:foreman-installer-1.15.6.11-1.el7sat.noarch
Summary: Non-fatal POSTIN scriptlet failure in rpm package 1:foreman-installer-1.15.6....
Keywords:
Status: CLOSED DUPLICATE of bug 1576443
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Upgrades
Version: 6.3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-20 03:04 UTC by Sam Yangsao
Modified: 2018-06-25 15:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-22 20:02:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sam Yangsao 2018-06-20 03:04:56 UTC
Description of problem:

yum update to upgrade a Satellite 6.3.1 server/capsule to Satellite 6.3.2 fails with the following error:

warning: %post(foreman-installer-1:1.15.6.11-1.el7sat.noarch) scriptlet failed, exit status 27
Non-fatal POSTIN scriptlet failure in rpm package 1:foreman-installer-1.15.6.11-1.el7sat.noarch

Version-Release number of selected component (if applicable):

Satellite 6.3.1
Satellite 6.3.2
RHEL 7.5

How reproducible:

Always?

Steps to Reproduce:

1.  Run a 'yum update' on either a Satellite 6.3.1 server or capsule

Actual results:

# Satellite 6.3.1 server
[...]
  Updating   : kernel-tools-libs-3.10.0-862.3.3.el7.x86_64                                        23/144 
  Updating   : tfm-rubygem-runcible-1.12.0.6-1.el7sat.noarch                                      24/144 
  Updating   : 1:foreman-installer-1.15.6.11-1.el7sat.noarch                                      25/144 
warning: %post(foreman-installer-1:1.15.6.11-1.el7sat.noarch) scriptlet failed, exit status 27
Non-fatal POSTIN scriptlet failure in rpm package 1:foreman-installer-1.15.6.11-1.el7sat.noarch
  Updating   : katello-installer-base-3.4.5.32-1.el7sat.noarch                                    26/144 
  Updating   : foreman-installer-katello-3.4.5.32-1.el7sat.noarch                                 27/144 
  Updating   : foreman-proxy-content-3.4.5-18.el7sat.noarch                                       28/144 
[...]

# Satellite 6.3.1 capsule
[...]
  Updating   : python-qpid-proton-0.16.0-11.el7.x86_64                                            10/90 
  Updating   : python-gofer-2.7.8-1.el7.noarch                                                    11/90 
  Updating   : python-pulp-docker-common-2.4.1.1-1.el7sat.noarch                                  12/90 
  Updating   : 1:foreman-installer-1.15.6.11-1.el7sat.noarch                                      13/90 
warning: %post(foreman-installer-1:1.15.6.11-1.el7sat.noarch) scriptlet failed, exit status 27
Non-fatal POSTIN scriptlet failure in rpm package 1:foreman-installer-1.15.6.11-1.el7sat.noarch
  Updating   : katello-installer-base-3.4.5.32-1.el7sat.noarch                                    14/90 
  Updating   : foreman-installer-katello-3.4.5.32-1.el7sat.noarch                                 15/90 
  Updating   : foreman-proxy-content-3.4.5-18.el7sat.noarch                                       16/90 
  Updating   : satellite-common-6.3.2-1.el7sat.noarch                                             17/90 
  Updating   : kernel-tools-libs-3.10.0-862.3.3.el7.x86_64                                        18/90 
[...]

Expected results:

'yum update' should not encounter any errors

Additional info:

Reproducer is available on the RH network for review

Comment 1 Sam Yangsao 2018-06-20 17:14:12 UTC
Just to add, 'yum update' did finish and the upgrade completed successfully.  Not sure why we're getting the post error though.  Thanks!

Comment 3 Brad Buckingham 2018-06-22 20:02:39 UTC
This looks like it may be a duplicate of bug 1576443; therefore, closing.  Please feel free to re-open, if it is different. Thanks!

*** This bug has been marked as a duplicate of bug 1576443 ***

Comment 4 Andrew 2018-06-25 15:17:46 UTC
This bug affects version Satellite 6.3.1 and 6.4.  One would think that would be noted in the bug 1576443 posting.


Note You need to log in before you can comment on or make changes to this bug.