Bug 1593100 - [CephFS]: mds crash if client get evicted in the middle of mds failover
Summary: [CephFS]: mds crash if client get evicted in the middle of mds failover
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
low
high
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: subhash
URL:
Whiteboard:
Depends On:
Blocks: 1611056
TreeView+ depends on / blocked
 
Reported: 2018-06-20 03:48 UTC by Yan, Zheng
Modified: 2018-08-09 18:27 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-12.2.4-32 Ubuntu: ceph_12.2.4-36redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 23946 None None None 2018-06-20 03:48:23 UTC
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:27:42 UTC

Description Yan, Zheng 2018-06-20 03:48:24 UTC
Description of problem:

If clients get evicted in the middle of mds failover,there is a chance that ceph-mds crashes.

How reproducible:


Steps to Reproduce:
1. Setup 3 active mds, 1 ceph-fuse client, run metadata extensive workload (such as fsstss -p 16 ...)
2. Restart 2 mds. When one recovering mds enter rejoin state, kill the client by using 'ceph daemon mds.xxx session evict xxx'

Actual results:

ceph-mds may crash

Expected results:

ceph-mds does not crash

Additional info:

Comment 3 Yan, Zheng 2018-06-20 07:28:56 UTC
zhyan-laptop:ceph zhyan$ git push rh-ceph ceph-3.0-rhel-patches 
Counting objects: 62, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (57/57), done.
Writing objects: 100% (62/62), 11.35 KiB | 726.00 KiB/s, done.
Total 62 (delta 54), reused 5 (delta 5)
remote: Resolving deltas: 100% (54/54)
remote: Processing changes: refs: 1, done    
To ssh://code.engineering.redhat.com/ceph/.git
   0b3592f04c..1e9171374c  ceph-3.0-rhel-patches -> ceph-3.0-rhel-patches

Comment 13 subhash 2018-08-02 15:56:29 UTC
MDS version: ceph version 12.2.4-45redhat1xenial

followed the steps from desc,mds no longer crashes when the client is evicted.

Moving to verified state

Comment 15 errata-xmlrpc 2018-08-09 18:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.