Bug 1593212 - --enable-network got broken by commit disabling host_resolv
Summary: --enable-network got broken by commit disabling host_resolv
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1610717 1618409 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-20 09:49 UTC by Jaroslav Škarvada
Modified: 2018-10-10 20:14 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-08-16 08:06:41 UTC


Attachments (Terms of Use)
Proposed fix (2.85 KB, patch)
2018-06-20 09:49 UTC, Jaroslav Škarvada
no flags Details | Diff

Description Jaroslav Škarvada 2018-06-20 09:49:37 UTC
Created attachment 1453169 [details]
Proposed fix

Description of problem:
This is caused by the commit:
https://github.com/rpm-software-management/mock/commit/39d9b551dd75c0e082eae93d18cd4a0cd5306bf8

The problem is that util.load_config() is called before util.set_config_opts_per_cmdline(), so the config_opts['rpmbuild_networking'] is not yet set when the resolver is setup. Attached patch tries to address it.

Version-Release number of selected component (if applicable):
mock-1.4.11-2.fc29

How reproducible:
Always

Steps to Reproduce:
1. mock -r fedora-rawhide-x86_64 install iputils
2. mock -r fedora-rawhide-x86_64 shell
3. ping seznam.cz

Actual results:
No resolv

Expected results:
Successful ping

Additional info:

Comment 1 Miroslav Suchý 2018-06-20 11:42:24 UTC
Committed as b861d15.
Thank you.

Comment 2 Miroslav Suchý 2018-08-02 11:38:05 UTC
*** Bug 1610717 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-08-13 19:52:24 UTC
mock-core-configs-29.1-1.fc28 distribution-gpg-keys-1.22-1.fc28 mock-1.4.13-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a6fe7bfae0

Comment 4 Fedora Update System 2018-08-13 19:52:39 UTC
distribution-gpg-keys-1.22-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-adfd38b8b9

Comment 5 Fedora Update System 2018-08-13 19:52:54 UTC
mock-core-configs-29.1-1.fc27 distribution-gpg-keys-1.22-1.fc27 mock-1.4.13-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4aeec4e04e

Comment 6 Fedora Update System 2018-08-13 19:53:08 UTC
mock-core-configs-29.1-1.el7 distribution-gpg-keys-1.22-1.el7 mock-1.4.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-68b5e45991

Comment 7 Jan Kurik 2018-08-14 11:18:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 8 Fedora Update System 2018-08-14 20:36:27 UTC
distribution-gpg-keys-1.22-1.fc27, mock-1.4.13-1.fc27, mock-core-configs-29.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4aeec4e04e

Comment 9 Fedora Update System 2018-08-14 21:19:40 UTC
distribution-gpg-keys-1.22-1.el7, mock-1.4.13-1.el7, mock-core-configs-29.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-68b5e45991

Comment 10 Fedora Update System 2018-08-14 21:42:59 UTC
distribution-gpg-keys-1.22-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-adfd38b8b9

Comment 11 Fedora Update System 2018-08-14 22:42:00 UTC
distribution-gpg-keys-1.22-1.fc28, mock-1.4.13-1.fc28, mock-core-configs-29.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a6fe7bfae0

Comment 12 Fedora Update System 2018-08-16 08:06:41 UTC
distribution-gpg-keys-1.22-1.fc28, mock-1.4.13-1.fc28, mock-core-configs-29.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-08-16 15:27:57 UTC
distribution-gpg-keys-1.22-1.el7 mock-1.4.13-1.el7 mock-core-configs-29.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-68b5e45991

Comment 14 Fedora Update System 2018-08-16 15:28:19 UTC
distribution-gpg-keys-1.22-1.fc27 mock-1.4.13-1.fc27 mock-core-configs-29.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4aeec4e04e

Comment 15 Miro Hrončok 2018-08-16 16:25:08 UTC
*** Bug 1618409 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2018-08-17 13:35:25 UTC
distribution-gpg-keys-1.22-1.fc27, mock-1.4.13-1.fc27, mock-core-configs-29.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4aeec4e04e

Comment 17 Fedora Update System 2018-08-17 15:55:34 UTC
distribution-gpg-keys-1.22-1.el7, mock-1.4.13-1.el7, mock-core-configs-29.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-68b5e45991

Comment 18 Alexandre Oliva 2018-08-17 19:41:36 UTC
I'm not sure whether this is related, but I'm now getting:

# mock -r fedora-29-x86_64 shell
INFO: mock.py version 1.4.13 starting (python version = 3.6.6)...
[...]
Start: dnf install
Error: Failed to synchronize cache for repo 'fedora'
ERROR: Command failed: 
 # /usr/bin/dnf --installroot /var/lib/mock/fedora-29-x86_64/root/ --releasever 29 --disableplugin=local --setopt=deltarpm=False install @buildsys-build
Error: Failed to synchronize cache for repo 'fedora'

[root@vmi127185 mock]# rpm -q mock mock-core-configs
mock-1.4.13-1.fc28.noarch
mock-core-configs-29.1-1.fc28.noarch

Comment 19 Alexandre Oliva 2018-08-17 19:57:17 UTC
The [fedora] repo's metalink in the mock config resolves to 'https://mirrors.fedoraproject.org/metalink?repo=fedora-29&arch=x86_64'
but curl says:
[...]
# repo = fedora-29 arch = x86_64 error: invalid repo or arch

Broken URL, or outdated metalink server?

Comment 20 Alexandre Oliva 2018-08-17 20:11:57 UTC
Looks like the base repos for f29 are (still) missing

Comment 21 Alexandre Oliva 2018-08-18 21:31:22 UTC
... and now they're there.

Comment 22 Fedora Update System 2018-08-30 03:51:47 UTC
distribution-gpg-keys-1.22-1.fc27, mock-1.4.13-1.fc27, mock-core-configs-29.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2018-09-14 12:00:01 UTC
distribution-gpg-keys-1.23-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-07adf03b88

Comment 24 Fedora Update System 2018-09-14 23:15:30 UTC
distribution-gpg-keys-1.23-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-07adf03b88

Comment 25 Fedora Update System 2018-09-22 22:56:31 UTC
distribution-gpg-keys-1.22-1.el7, mock-1.4.13-1.el7, mock-core-configs-29.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2018-10-10 20:14:42 UTC
distribution-gpg-keys-1.23-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.