Bug 1593253 - installer missing --upgrade-mongo-storage option
Summary: installer missing --upgrade-mongo-storage option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Released
Assignee: Chris Roberts
QA Contact: Perry Gagne
URL: https://projects.theforeman.org/issue...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-20 11:45 UTC by Ales Dujicek
Modified: 2019-10-07 17:17 UTC (History)
11 users (show)

Fixed In Version: katello-installer-base-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:37:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:37:34 UTC
Foreman Issue Tracker 24066 None None None 2018-06-25 15:25:23 UTC
Foreman Issue Tracker 25634 None None None 2018-12-05 20:32:18 UTC

Description Ales Dujicek 2018-06-20 11:45:12 UTC
Description of problem:

during upgrade from 6.3 to 6.4 I am asked to run satellite-installer --upgrade-mongo-storage

/var/log/foreman-installer/satellite.log
[ INFO 2018-06-20T04:47:27 main] Upgrade Step: mongo_mmapv1_check...
[DEBUG 2018-06-20T04:47:28 main] systemctl stop mongod finished successfully!
[ INFO 2018-06-20T04:47:28 main] Detecting Pulp database and no wiredTiger files, keeping storage engine as MMAPv1
[ INFO 2018-06-20T04:47:28 main] To upgrade to wiredTiger at a later time run foreman-installer with the --upgrade-mongo-storage flag.
[ INFO 2018-06-20T04:47:28 main] Upgrade Step: Running installer...

https://github.com/Katello/katello-installer/blob/00105a73b6da68d6051ed8a62e380b263f2bc6ec/hooks/pre/30-upgrade.rb#L63

but:
# satellite-installer --upgrade-mongo-storage
ERROR: Unrecognised option '--upgrade-mongo-storage'

See: 'satellite-installer --help'


Version-Release number of selected component (if applicable):
foreman-installer-katello-3.7.0-1.rc1.el7sat.noarch
satellite-installer-6.4.0.5-1.beta.el7sat.noarch
foreman-installer-1.18.0-0.1.RC1.el7sat.noarch
katello-installer-base-3.7.0-1.rc1.el7sat.noarch


How reproducible:
always

Comment 2 pm-sat@redhat.com 2018-06-20 22:27:26 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23030 has been resolved.

Comment 3 pm-sat@redhat.com 2018-07-11 12:26:34 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 4 pm-sat@redhat.com 2018-07-11 12:26:37 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 12 Ewoud Kohl van Wijngaarden 2019-04-30 14:45:39 UTC
Related: https://bugzilla.redhat.com/show_bug.cgi?id=1704806 is about the inconsistent naming in the option.

Comment 15 errata-xmlrpc 2019-05-14 12:37:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.