Bug 1593311 - Unable to repair damaged purge queue journal
Summary: Unable to repair damaged purge queue journal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
low
medium
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-20 14:13 UTC by Ram Raja
Modified: 2018-08-09 18:27 UTC (History)
4 users (show)

Fixed In Version: RHEL: ceph-12.2.4-32 Ubuntu: ceph_12.2.4-36redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 24107 None None None 2018-06-20 14:13:37 UTC
Ceph Project Bug Tracker 24604 None None None 2018-06-21 19:08:00 UTC
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:27:42 UTC

Description Ram Raja 2018-06-20 14:13:37 UTC
Description of problem:

Reported by community developer,
"In our online clusters, we encountered the https://tracker.ceph.com/issues/19593 . Although we cherry-pick the fixing commits, the purge queue's journal is already damaged. When trying to repair the journal, we found that the journal's head has not been updated for a long time, which is caused by PurgeQueue::_consume() method always returning true. So we think it might be necessary for this method to return false when there were actually no purge queue item executed, even if the https://tracker.ceph.com/issues/19593 is fixed. After all, there could be other bugs that could damage the journal."

Comment 17 errata-xmlrpc 2018-08-09 18:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.