Bug 1593411 - gfs2-utils uninstallable on i686
Summary: gfs2-utils uninstallable on i686
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gfs2-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andrew Price
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2018-06-20 18:37 UTC by Richard W.M. Jones
Modified: 2018-06-22 19:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-21 10:00:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2018-06-20 18:37:08 UTC
Description of problem:

DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem: conflicting requests
DEBUG util.py:439:    - nothing provides kmod(dlm.ko) needed by gfs2-utils-3.2.0-1.fc29.i686

I believe this is likely fallout from the kernel developers
deciding to break/drop/whatever the kernel on i686.

Version-Release number of selected component (if applicable):

gfs2-utils-3.2.0-1.fc29.i686

How reproducible:

100%

Steps to Reproduce:
1. Install gfs2-utils

Comment 1 Andrew Price 2018-06-21 10:00:41 UTC
This should be fixed in gfs2-utils-3.2.0-2.fc29 which weakens the kmod dependencies. Thanks.


Note You need to log in before you can comment on or make changes to this bug.