Bug 1593660 - port patch for #1458122 to python34 (UnixCCompiler causes "maximum recursion depth exceeded")
Summary: port patch for #1458122 to python34 (UnixCCompiler causes "maximum recursion ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python34
Version: epel7
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Carl George
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1458122
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-21 10:39 UTC by Felix Schwarz
Modified: 2019-04-24 23:28 UTC (History)
7 users (show)

Fixed In Version: python34-3.4.9-2.el7 python34-3.4.10-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-23 02:49:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Felix Schwarz 2018-06-21 10:39:16 UTC
EPEL's python34 still has the buggy "Python-3.1.1-rpath.patch" which contains a bug (can cause endless recursion)

How to reproduce:
  pip3 install cupy==2.2.0
(or any cupy version which does not provide precompiled wheels for 2.2)

The solution is the same as for bug 1458122: replace "super(self.__class__, self)._fix_lib_args(...)" with "super()._fix_lib_args(...)".

Comment 1 Petr Viktorin 2019-01-21 13:30:18 UTC
This bug has low priority for me. If you'd like to take it, please go ahead!

(Carl, would you like to help?)

Comment 2 Felix Schwarz 2019-01-23 21:34:32 UTC
Actually I switched to python36 which is in EPEL as well - the bug is not happening there. Also python36 is the future for EPEL7 so I'm just closing this bug report.

Feel free to reopen if python34 is still important to you.

Comment 3 Petr Viktorin 2019-01-24 10:16:57 UTC
It should be fixed eventually.

Comment 4 Carl George 2019-01-31 21:15:59 UTC
Felix, is there any other way to reproduce this that doesn't require a CUDA environment?  Updating the rpath patch looks simple enough, but I want to be able to test it and confirm doing that works.

Comment 5 Felix Schwarz 2019-02-01 08:46:48 UTC
Unfortunately this was the only case I noticed.

If it really helps I could try to build a clean test case based on cupy but as I switched to EPELs python36 I can't justify spending a lot of time on this. However I just verified the problem still exists in CentOS/EPEL 7 with one minor change: I was unable to reproduce the issue with cupy 2.2.0 but the most recent release (5.2.0) triggered the bug ("pip3 install cupy").

Comment 6 Petr Viktorin 2019-02-04 13:32:12 UTC
I think it's OK to just do sanity testing here – merge it if it doesn't break anything on your machine.

Comment 7 Felix Schwarz 2019-02-04 13:39:35 UTC
Also if you have a koji build I can manually test on a cuda-enabled machine.

Comment 8 Carl George 2019-02-04 20:38:45 UTC
https://src.fedoraproject.org/rpms/python34/pull-request/22

Felix, you can test with the simple-koji-ci build.

https://koji.fedoraproject.org/koji/taskinfo?taskID=32537652

Comment 9 Felix Schwarz 2019-02-04 21:05:07 UTC
(In reply to Carl George from comment #8)
> Felix, you can test with the simple-koji-ci build.
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=32537652

Yes, that build worked for me just fine (created a new venv and compiled the cupy package).

Comment 10 Carl George 2019-02-04 21:07:52 UTC
Petr, if you can merge that PR I'll handle the build and bodhi update.

Comment 11 Miro Hrončok 2019-02-04 23:44:32 UTC
I've merged it.

Comment 12 Fedora Update System 2019-02-05 17:19:23 UTC
python34-3.4.9-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-291617361b

Comment 13 Fedora Update System 2019-02-07 23:42:36 UTC
python34-3.4.9-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-291617361b

Comment 14 Fedora Update System 2019-02-23 02:49:59 UTC
python34-3.4.9-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-04-08 04:07:01 UTC
python34-3.4.10-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-73e99f4a82

Comment 16 Fedora Update System 2019-04-09 02:44:09 UTC
python34-3.4.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-73e99f4a82

Comment 17 Fedora Update System 2019-04-24 23:28:22 UTC
python34-3.4.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.