Bug 1593758 - [RFE][ironic] Redfish driver to manage BIOS configuration
Summary: [RFE][ironic] Redfish driver to manage BIOS configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 15.0 (Stein)
Assignee: Ilya Etingof
QA Contact: mlammon
URL:
Whiteboard:
: 1478782 (view as bug list)
Depends On:
Blocks: 1339072 1476902 1577362
TreeView+ depends on / blocked
 
Reported: 2018-06-21 14:26 UTC by Ilya Etingof
Modified: 2019-09-26 10:45 UTC (History)
12 users (show)

Fixed In Version: openstack-ironic-12.1.2-0.20190615000404.c3cbdb5.el8ost
Doc Type: Technology Preview
Doc Text:
Red Hat OpenStack Platform Bare Metal service (ironic) now has a BIOS management interface, with which you can inspect and modify a device’s BIOS configuration. In Red Hat OpenStack Platform 15, the Bare Metal service supports BIOS management capabilities for data center devices that are Redfish API compliant. The Bare Metal service implements Redfish calls through the Python library, Sushy.
Clone Of:
Environment:
Last Closed: 2019-09-21 11:16:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack Storyboard 2001791 0 None None None 2018-08-29 17:05:36 UTC
OpenStack gerrit 570555 0 None MERGED Introduce BIOS API 2021-01-20 15:04:38 UTC
OpenStack gerrit 582314 0 None MERGED Add BIOS interface to Redfish hardware type 2021-01-20 15:04:38 UTC
OpenStack gerrit 628681 0 None MERGED Undercloud: support bios interface for ilo, irmc, redfish 2021-01-20 15:04:38 UTC
Red Hat Bugzilla 1478782 0 high CLOSED [CMCC][RFE] [ironic] automation of BIOS configuration 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1632682 0 unspecified CLOSED [RFE][ironic] Support Redfish Message Registries 2021-02-22 00:41:40 UTC

Internal Links: 1478782 1632682

Description Ilya Etingof 2018-06-21 14:26:27 UTC
With the introduction of the BIOS management interface in ironic [1] it is now possible to inspect and modify BIOS configuration through BMCs that support system BIOS access.

Redfish protocol features BIOS management [2] capabilities. This bug is to implement BIOS management interface at the ironic Redfish hardware type.

1. https://specs.openstack.org/openstack/ironic-specs/specs/not-implemented/generic-bios-config.html
2. https://www.dmtf.org/sites/default/files/standards/documents/DSP2046_2017.0a.pdf  (p. 20)

Comment 1 Dmitry Tantsur 2018-06-21 15:15:56 UTC
Assigning you Ilya simply because we need someone to track it, and you're on this topic right now.

Comment 2 Dmitry Tantsur 2018-09-25 09:36:21 UTC
Purging patches a bit. Ilya, do we need to track message registry in the same RFE? It may take substantially more time than getting some BIOS support done.

Comment 3 Ilya Etingof 2018-09-25 10:14:41 UTC
I'd propose to track message registry separately because:

1) In simple cases, BIOS management should be reasonably operational without message registries
2) In discussions with DMTF those registries proved to be a non-trivial matter from both technical and legal perspectives

Once we get message registries feature resolved, we could update our BIOS implementation to leverage them.

Comment 4 Dmitry Tantsur 2018-09-25 10:21:08 UTC
That's my thinking as well. Let's then create a separate RFE and move the related patches there. The patches list here is scary :)

Comment 5 Bob Fournier 2018-09-25 15:03:29 UTC
*** Bug 1478782 has been marked as a duplicate of this bug. ***

Comment 8 Bob Fournier 2019-01-04 19:38:09 UTC
It looks like this can move to POST as all patches have landed correct?

Do we also plan on landing the Message Registry RFE in OSP-15?  Also as TechPreview?

Comment 9 Dmitry Tantsur 2019-01-05 20:09:13 UTC
I think we need TripleO integration for BIOS, at least https://review.openstack.org/#/c/628681/

Comment 15 Ilya Etingof 2019-06-19 17:00:39 UTC
Please, review doctext.

Comment 17 Ilya Etingof 2019-06-25 07:29:16 UTC
The new doctext seems correct to me.

Comment 22 errata-xmlrpc 2019-09-21 11:16:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.