Bug 1593805 - Better understanding of NSS_USE_DECODED_CKA_EC_POINT for ECC
Summary: Better understanding of NSS_USE_DECODED_CKA_EC_POINT for ECC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Christina Fu
QA Contact: Asha Akkiangady
URL:
Whiteboard:
Depends On:
Blocks: 1611250
TreeView+ depends on / blocked
 
Reported: 2018-06-21 15:33 UTC by Geetika Kapoor
Modified: 2018-10-30 11:07 UTC (History)
3 users (show)

Fixed In Version: pki-core-10.5.9-6.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1611250 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:07:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3195 None None None 2018-10-30 11:07:43 UTC

Description Geetika Kapoor 2018-06-21 15:33:29 UTC
Description of problem:

QE faced installation issues  where if NSS_USE_DECODED_CKA_EC_POINT=1 is set and do a pki-server subsystem-cert-validate on ca signing cert it gives validation error.

Not sure if we need NSS_USE_DECODED_CKA_EC_POINT=1 for ECC. If it is not needed,
probably we can remove it from HttpClient files and in that case RHCS documents also needs to be changed.

Version-Release number of selected component (if applicable):
10.5 update 2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Christina Fu 2018-08-01 22:51:24 UTC
commit efe9bf15b30e90aaea5519e36a35e19b10d69b19 (HEAD -> master, origin/master, origin/HEAD, bug1593805-ECC-env-master)
Author: Christina Fu <cfu@cfu-fedora.usersys.redhat.com>
Date:   Wed Aug 1 15:22:03 2018 -0700

    Bug 1593805  Better understanding of NSS_USE_DECODED_CKA_EC_POINT for ECC
    
    This patch removes the outdated reference to EC environment variable
    NSS_USE_DECODED_CKA_EC_POINT for ECC in the HttpClient command line usage.
    
    More info in the usage are updated as well for correctness and clarity.
    
    Change-Id: I60fc56eee1e94c73f401a5d46ea3ea9f1aa0a4c0

Comment 7 Geetika Kapoor 2018-08-27 10:27:26 UTC
verification Step:

Make sure httpclient help doesn't show NSS_USE_DECODED_CKA_EC_POINT=1 for ECC setup.

Comment 9 errata-xmlrpc 2018-10-30 11:07:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3195


Note You need to log in before you can comment on or make changes to this bug.