Bug 1593851 - FFU Issue during OSP11->OSP12 on Director (openstack-nova-cert)
Summary: FFU Issue during OSP11->OSP12 on Director (openstack-nova-cert)
Keywords:
Status: CLOSED DUPLICATE of bug 1573290
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: All
OS: All
medium
medium
Target Milestone: zstream
: ---
Assignee: Sofer Athlan-Guyot
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-21 16:47 UTC by Darin Sorrentino
Modified: 2018-08-07 13:08 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-26 16:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Darin Sorrentino 2018-06-21 16:47:08 UTC
Description of problem:

After performing a FFU upgrade of Director from OSP11 to OSP12, I believe the openstack-nova-cert services is/was decommissioned however it still shows in the compute list output.

(undercloud) [stack@ds-hf-ca-undercloud ~]$  openstack compute service list
+----+----------------+-----------------------------------+----------+---------+-------+----------------------------+
| ID | Binary         | Host                              | Zone     | Status  | State | Updated At                 |
+----+----------------+-----------------------------------+----------+---------+-------+----------------------------+
|  1 | nova-cert      | ds-hf-ca-undercloud.hextupleo.lab | internal | enabled | down  | 2018-06-21T16:17:43.000000 |
|  2 | nova-scheduler | ds-hf-ca-undercloud.hextupleo.lab | internal | enabled | up    | 2018-06-21T16:37:44.000000 |
|  3 | nova-conductor | ds-hf-ca-undercloud.hextupleo.lab | internal | enabled | up    | 2018-06-21T16:37:50.000000 |
|  4 | nova-compute   | ds-hf-ca-undercloud.hextupleo.lab | nova     | enabled | up    | 2018-06-21T16:37:49.000000 |
+----+----------------+-----------------------------------+----------+---------+-------+----------------------------+
(undercloud) [stack@ds-hf-ca-undercloud ~]$ 
(undercloud) [stack@ds-hf-ca-undercloud ~]$ systemctl | grep nova
  openstack-nova-api.service                                                loaded active running   OpenStack Nova API Server
  openstack-nova-compute.service                                            loaded active running   OpenStack Nova Compute Server
  openstack-nova-conductor.service                                          loaded active running   OpenStack Nova Conductor Server
  openstack-nova-scheduler.service                                          loaded active running   OpenStack Nova Scheduler Server
(undercloud) [stack@ds-hf-ca-undercloud ~]$ 


I imagine this is harmless since I looked at a straight installation of OSP12 and this service does not exist, however it should probably be cleaned up as part of the upgrade from 11 to 12.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Carlos Camacho 2018-07-02 12:21:42 UTC
(Triaging, already assigned) Please feel free to remove the Triage keyword if you believe so.

Comment 6 Ollie Walsh 2018-07-26 16:48:10 UTC

*** This bug has been marked as a duplicate of bug 1573290 ***


Note You need to log in before you can comment on or make changes to this bug.