Bug 15940 - Cybercash Authorization Bug
Summary: Cybercash Authorization Bug
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Store   
(Show other bugs)
Version: current
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Garth Webb
QA Contact: Paul Lindner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-10 19:18 UTC by Paul Lindner
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 00:08:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Lindner 2000-08-10 19:18:11 UTC
It appears that we are not sending the correct amount to Cybercash for 
authorization on an order from the Web store.  The problem occurs when
the order quantity is greater than 1.  The amount authorized appears to 
be the sum of unit prices for all lines.  It should be the sum of 
extended prices for all lines.  For example, web order number W2170939:  

Item            Qty     Unit Price      Extended
Price                          
RH12000         2       179.95         
359.90                                  
20003XL         1       0              
0                                       
CATAX           1       13.05          
13.05                                  
 FREIGHT         1       12.95          
12.95                                                          
---------       ---------                               
total                   205.95         
385.90                                                                                                          

The amount authorized was $205.95.  The amount we attempted to
mark/settle through Cybercash was
$385.90.                                                                                                                                                                                                         
Please fix as soon as possible as Cybercash will reject the
subsequent          marking/settlement against the credit card because the
total amount 
exceeds the amount authorized.  I must manually resubmit these charges
for settlement.

Comment 1 Garth Webb 2000-08-11 00:11:26 UTC
This situation only happened when the user typed a different number for the
quantity and then clicked 'Checkout' (rather than clicking 'Recalculate
Order').  This has been fixed.


Note You need to log in before you can comment on or make changes to this bug.