Bug 1594323 - umount on evicted kclient blocks forever
Summary: umount on evicted kclient blocks forever
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-22 15:49 UTC by Ram Raja
Modified: 2018-08-09 18:27 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-12.2.4-32 Ubuntu: ceph_12.2.4-36redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 24188 None None None 2018-06-22 15:49:57 UTC
Red Hat Bugzilla 1548588 None None None Never
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:27:32 UTC

Internal Links: 1548588

Description Ram Raja 2018-06-22 15:49:58 UTC
Description of problem:
Unmount on evicted Ceph kernel client blocks forever.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Mount ceph filesystem using kernel client. So something like,
   ```
   sudo mount.ceph 10.215.99.65:40673:/ /home/rraja/cephfs/ -o name=admin,secret=AQAUzixbe714KxAAUlKEnp++jPPznuE/Lozk0g==
   ```
2. Evict the kernel client,
   ```
   ceph tell mds.0 client evict id=<client-id>
   ```
   you can figure out the client ID by using the following command to list the clients, and matching client.metadata

3. Try unmounting for 30 sec
   ```
   sudo umount  /home/rraja/cephfs/
   ```    

Actual results:
Umount fails (with device busy)

Expected results:
Umount succeeds


Additional info:

Comment 5 Ram Raja 2018-06-22 16:02:32 UTC
> 
3. Try unmounting for 30 sec
   ```
   sudo umount  /home/rraja/cephfs/
   ```   

Meant to say try unmounting. Ignore the 'try for 30 seconds bit'.

Comment 6 Ram Raja 2018-06-22 16:04:25 UTC
(In reply to Ram Raja from comment #0)
> Description of problem:
> Unmount on evicted Ceph kernel client blocks forever.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. Mount ceph filesystem using kernel client. So something like,
>    ```
>    sudo mount.ceph 10.215.99.65:40673:/ /home/rraja/cephfs/ -o
> name=admin,secret=AQAUzixbe714KxAAUlKEnp++jPPznuE/Lozk0g==
>    ```
> 2. Evict the kernel client,
>    ```
>    ceph tell mds.0 client evict id=<client-id>
>    ```
>    you can figure out the client ID by using the following command to list
> the clients, and matching client.metadata
> 
> 3. Try unmounting for 30 sec
>    ```
>    sudo umount  /home/rraja/cephfs/
   ```    

Just umount once, and don't need to repeat for 30 seconds

> 
> Actual results:
> Umount fails (with device busy)
> 
> Expected results:
> Umount succeeds
> 
> 
> Additional info:

Comment 7 Ram Raja 2018-06-22 16:11:18 UTC
(In reply to Ram Raja from comment #6)
> (In reply to Ram Raja from comment #0)
> > Description of problem:
> > Unmount on evicted Ceph kernel client blocks forever.
> > 
> > Version-Release number of selected component (if applicable):
> > 
> > 
> > How reproducible:
> > 
> > 
> > Steps to Reproduce:
> > 1. Mount ceph filesystem using kernel client. So something like,
> >    ```
> >    sudo mount.ceph 10.215.99.65:40673:/ /home/rraja/cephfs/ -o
> > name=admin,secret=AQAUzixbe714KxAAUlKEnp++jPPznuE/Lozk0g==
> >    ```
> > 2. Evict the kernel client,
> >    ```
> >    ceph tell mds.0 client evict id=<client-id>
> >    ```
> >    you can figure out the client ID by using the following command to list
> > the clients, and matching client.metadata
> > 
> > 3. Try unmounting for 30 sec
> >    ```
> >    sudo umount  /home/rraja/cephfs/
>    ```    
> 
> Just umount once, and don't need to repeat for 30 seconds

And please force umount instead of just umount,
```
sudo umount -f /home/rraja/cephfs/
```

> 
> > 
> > Actual results:
> > Umount fails (with device busy)
> > 
> > Expected results:
> > Umount succeeds
> > 
> > 
> > Additional info:

Comment 17 errata-xmlrpc 2018-08-09 18:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.