Bug 1594331 - gluster-block: defend on minimum kernel version recommendation at runtime
Summary: gluster-block: defend on minimum kernel version recommendation at runtime
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: OCS 3.11
Assignee: Prasanna Kumar Kalever
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1595628 1629575
TreeView+ depends on / blocked
 
Reported: 2018-06-22 16:04 UTC by Prasanna Kumar Kalever
Modified: 2018-10-24 04:54 UTC (History)
15 users (show)

Fixed In Version: gluster-block-0.2.1-27.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, using gluster-block on a non-recommended kernel version, resulted in dependent user space processes entering an uninterruptible sleep state. With this update, gluster-block now checks for minimum kernel version. If the minimum recommendation is not met, then gluster-block service refuse to start. As a result we achieve stabilized gluster-block user experience.
Clone Of:
: 1595628 (view as bug list)
Environment:
Last Closed: 2018-10-24 04:52:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2987 None None None 2018-10-24 04:54:38 UTC

Description Prasanna Kumar Kalever 2018-06-22 16:04:29 UTC
Description of problem:

Since there is a chance that one didn't upgrade RHEL but they did come upto latest RHGS through rhgs channel subscription, so technically one can land into running latest RHGS on old RHEL versions as well, so it is better that we defend minimum kernel version (would be 3.10.0-693) for gluster-block. 

It would have to be some sort of a runtime check rather than a packaging/install check as it would be CNS deploy (containers).

Comment 18 Anjana KD 2018-10-11 06:58:23 UTC
Updated the Doc Text in the Doc Text field. Kindly review.

Comment 20 Anjana KD 2018-10-12 05:14:34 UTC
Thankyou, Have updated the doc text.

Comment 22 errata-xmlrpc 2018-10-24 04:52:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2987


Note You need to log in before you can comment on or make changes to this bug.