Bug 1594620 - CephFS Client library (ceph-fuse) should drop file cache capability after invalidating its cache
Summary: CephFS Client library (ceph-fuse) should drop file cache capability after inv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: All
OS: All
low
low
Target Milestone: z5
: 3.0
Assignee: Patrick Donnelly
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-25 02:31 UTC by Patrick Donnelly
Modified: 2018-08-09 18:27 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-12.2.4-32 Ubuntu: ceph_12.2.4-36redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 18:27:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 22688 None None None 2018-06-25 02:31:25 UTC
Red Hat Product Errata RHBA-2018:2375 None None None 2018-08-09 18:27:32 UTC

Description Patrick Donnelly 2018-06-25 02:31:26 UTC
Description of problem:

Hang may be caused by client not removing file cache capability from wanted set after dropping its cache for a given file.

How reproducible:

Not easily reproducible. Marking this as CodeChange.

Comment 10 errata-xmlrpc 2018-08-09 18:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2375


Note You need to log in before you can comment on or make changes to this bug.