Bug 1594729 - New selinux-policy causes openvswitch_t/modules_object_t AVC denial
Summary: New selinux-policy causes openvswitch_t/modules_object_t AVC denial
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-25 09:51 UTC by Jan Pazdziora
Modified: 2018-10-30 10:06 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.13.1-205.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:06:45 UTC

Description Jan Pazdziora 2018-06-25 09:51:42 UTC
Description of problem:

Using selinux-policy-3.13.1-204.el7, runninig

  systemctl start openvswitch

causes AVC denial.

Version-Release number of selected component (if applicable):

selinux-policy-3.13.1-204.el7.noarch
openvswitch-selinux-extra-policy-1.0-3.el7fdp.noarch
selinux-policy-3.13.1-204.el7.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. Enable FDP-7-RHEL-7 repo.
2. yum install -y openvswitch
3. systemctl start openvswitch
4. Check audit.log.

Actual results:

type=SYSCALL msg=audit(1529917649.263:181): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=5932f a2=1 a3=2 items=0 ppid=12154 pid=12185 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="modprobe" exe="/usr/bin/kmod" subj=system_u:system_r:openvswitch_t:s0 key=(null)
type=AVC msg=audit(1529917649.263:181): avc:  denied  { map } for  pid=12185 comm="modprobe" path="/usr/lib/modules/3.10.0-907.el7.x86_64/modules.dep.bin" dev="dm-0" ino=101044569 scontext=system_u:system_r:openvswitch_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0

Expected results:

No AVC denial.

Additional info:

This seems to be RHEL 7.6 version of Fedora bug 1508336 and bug 1508337.

This is a regression against RHEL 7.5's selinux-policy-3.13.1-192.el7_5.4.noarch.

Comment 5 Jan Tluka 2018-07-02 12:35:35 UTC
I noticed this bug with 7.5 distro when the kernel used was kernel-3.10.0-915.el7.

This issue did not occur with the same setup (same OVS and selinux-policy) and kernel-3.10.0-908.el7.

It looks like the issue is caused by some change in kernel behavior between these releases, though I have not bisected this yet.

Comment 8 errata-xmlrpc 2018-10-30 10:05:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.