Bug 15949 - Installer gets /etc/sysconfig/mouse wrong
Summary: Installer gets /etc/sysconfig/mouse wrong
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-10 20:43 UTC by Joshua Jensen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 22:07:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2000-08-10 20:43:26 UTC
In the installer, I select Microsoft IntelliMouse PS/2.

The FULLNAME variable in /etc/sysconfig/mouse says:
"Microsoft - IntelliMouse (PS/2)"

This really breaks gpm and X mouse functionality.
Running mouseconfig corrects things, as detailed below:

The FULLNAME line should be:
"Microsoft - IntelliMouse (PS/2)"

Looks like /etc/X11/XF86Config was broken by the installer using
Emulate3Buttons (which I *unchecked* because I didn't want it), and Device
/dev/psaux (instead of /dev/mouse... this part isn't really a bug, but why
not set up correctly like mouseconfig does?).

I have orignal and fixed config files, should you want to look at them.

Thanks

Joshua Jensen
joshua@iwsp.com
joshua@redhat.com

Comment 1 Joshua Jensen 2000-08-10 20:54:39 UTC
Sorry, I got the "fix" to /etc/sysconfig/mouse wrong before... here it is now:
The FULLNAME line should be:
"Microsoft IntelliMouse (PS/2)"



Comment 2 Matt Wilson 2000-08-10 22:07:12 UTC
fixed internally



Note You need to log in before you can comment on or make changes to this bug.