Bug 159545 - Managed email strings unused
Summary: Managed email strings unused
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
(Show other bugs)
Version: RHN Devel
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ken Ganong
QA Contact: Robin Norwood
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 151514
TreeView+ depends on / blocked
 
Reported: 2005-06-03 21:23 UTC by Ken Ganong
Modified: 2007-04-18 17:27 UTC (History)
1 user (show)

Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 20:27:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken Ganong 2005-06-03 21:23:45 UTC
Under the following url, a satellite user can set their own string templates for
pieces of emails.  In java, we are not respected one's ability to do such.
/internal/satellite/string_manager/index.pxt

Comment 1 Bret McMillan 2005-06-07 16:47:33 UTC
Are we just not using the string templates in the java code?

Comment 2 Ken Ganong 2005-06-09 19:12:13 UTC
Exactly.  We weren't using them at all.

Comment 3 Jesus M. Rodriguez 2005-06-10 18:35:01 UTC
Mass moving ON_DEV to ON_QA

Comment 4 Vlady Zlatkin 2005-07-03 22:00:45 UTC
testplan? is this a dupe of bug #159544?

Comment 5 Ken Ganong 2005-07-05 14:04:08 UTC
Not a dupe,   this bug was a blocker for 159544.  This bug should be fixed if QA
of 159544 goes well, but I'll leave it open simply because this includes any and
every email we sent through Java whereas the other bug refers to a single email.
 I know of three emails we send in Java:  Email Verification, You Have Account,
and New User.  If there are any I missed, they should also be using the Template
Strings (Monitoring emails perhaps).

Test Plan.
Login as an Org Admin on a Satellite.
Go to String Manager.
Change a couple of the managed email strings.
Go to Users.
Add a new user to your account.
Ensure that both emails (one to new user, one to admin) use the email strings
you changed.

Comment 6 Vlady Zlatkin 2005-07-05 22:30:43 UTC
fails

how can i get e-mail verification from a satellite?

it fails during password lookup,
http://fmoquete-64.rdu.redhat.com/help/forgot_password.pxt

there are two forms there, one fails, one i have to wait 5 mins to figure out
(won't let me submit twice quickly), but probably fails too.

Comment 7 Vlady Zlatkin 2005-07-05 22:32:25 UTC
also, any idea where this gets used:

 email_strings  	 email_account_info   	 Account Information:
Your RHN login: <login />
Your RHN email address: <email-address /> 

Comment 8 Ken Ganong 2005-07-06 14:58:52 UTC
email_account_info gets used in the 'email verfication' and 'user created' emails.
Email verification is apparently not done in satellite, we treat them as verified.
Therefore, the 'user created' email is probably the only Java one that that
particular template string can be seen and changed in a satellite.

Comment 9 Ken Ganong 2005-07-06 22:06:25 UTC
forgot_password now uses the email template strings.
forgot_accounts already did (surprisingly).

Comment 10 Bret McMillan 2005-07-26 01:15:41 UTC
Setting rnorwood as qa contact for java migration bugs

Comment 11 Robin Norwood 2005-07-26 22:27:54 UTC
Works in QA.


Note You need to log in before you can comment on or make changes to this bug.